WordPress.org

Support

Support » How-To and Troubleshooting » mod_rewrite problem (my host is oneandone.co.uk)

mod_rewrite problem (my host is oneandone.co.uk)

  • Hi there

    I installed WP 1.5 last week for the first time and was impressed with how easily it all installed itstelf. I didn’t run into any real problems until I started to play around with the permalinks

    My blog address is:
    http://www.jimhobbs.com/blog/

    I emailled my host – http://www.oneandone.co.uk – and asked them :

    > Can you tell me if my server supports the
    > Apache mod_rewrite module

    They replied : “Yes, the package does support mod rewrite”

    I ran the phpinfo file over at:
    http://www.jimhobbs.com/blog/info.php

    but can’t find mod_rewrite on there?
    Any ideas how I enable it or turn it on?

    The permalinks I would like is just the standard:
    /%year%/%monthnum%/%day%/%postname%/

    What am I doing wrong – I just get 404 errors when I click on the blog entry title. If I remove the option for fancy permalinks the blog works fine, but I would like to have the same structure as above. What further info would you need from myself to help me fix this ?

    Many thanks
    Jim
    http://www.jimhobbs.com/blog/

Viewing 15 replies - 1 through 15 (of 38 total)
  • btw, I’ve read and worked through

    http://codex.wordpress.org/Using_Permalinks

    But at the bottom of the page, on point 3:


    Fixing (.htaccess) Generation Issues
    If your installation of WordPress does not generate a .htaccess file or if it does not write the new rules onto your existing .htaccess file then there are a couple reasons that could be causing this. Work step by step and continue to the next step only if the step below does not work.

    Your server may not have the AllowOverride directive enabled. If the AllowOverride directive is set to None in your Apache httpd.config file, then .htaccess files are completely ignored. In this case, the server will not even attempt to read .htaccess files in the filesystem. When this directive is set to All, then any directive which has the .htaccess Context is allowed in .htaccess files. Example of enabled AllowOverride directive in httpd.config:
    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>
    If you don’t want to set AllowOverride to all (as it is above) then your AllowOverride list must include the FileInfo directive. You must restart your Apache server for any httpd.config file changes to take effect. For more information on which overrides are allowed, read about Apache Core Features (http://httpd.apache.org/docs-2.0/mod/core.html#allowoverride).

    where can I find the httpd.config file ?
    how can I restart my Apache server?

    I do already have a .htacces file generated, after following steps 1+2… is step 3 necessary?

    Still can’t get my permalinks to work

    See if this post helps: http://wordpress.org/support/topic.php?id=26666

    I’m on 1&1.com, so I imagine we should be similar.

    BTW, I’m on 1and1.co.uk and can verify that mod_rewrite is on.

    Thanks for the reponses guys

    [b]ifelse[/b]
    you wrote:
    >>BTW, I’m on 1and1.co.uk and can verify that mod_rewrite is on.

    Do you mean
    – You can verify that mod_rewrite is switched on with *my* account
    or
    – You can verify that mod_rewrite is switched on in general with a oneandone.co.uk account?

    [b]jennmiller[/b]
    I checked out out the thread you pointed to (26666) and tried out the two suggestions in there


    This worked for me just a couple of days ago using 1.5. I made a blank file in Notepad and named it .htaccess with no extension or anything like that. I ftp’d it to my root and that alone fixed everything. I hope this simple solution works for you

    This didn’t seem to do anything

    and likewise the following didn’t seem to work

    “Login to your server via FTP and get to spot where you can see the .htaccess file. Then, open your browser and go to Options/Permalinks. Now, delete the .htaccess file. After that, recreate your permalink rules. A working .htaccess file should have been created in place of the old/deleted one.”

    What should the CHMOD be for .htaccess…. 666 or 766

    I’m totally stumped and find it hard to figure where I’m going wrong given my very limited knowledge

    Do you mean
    – You can verify that mod_rewrite is switched on with *my* account
    or
    – You can verify that mod_rewrite is switched on in general with a oneandone.co.uk account?

    I meant that as mod_rewrite is turned on with my account, and because I did no special configuration, it strongly suggests that it would be the case in general.

    Giving the file 755 should be sufficient.

    ifelse :

    Wouldn’t the phpinfo file thing I ran tell me ?

    http://www.jimhobbs.com/blog/info.php

    I cannot see mod_rewrite on that page?
    (should it show up if it is enabled?)

    mod_rewrite existence doesn’t show up in phpinfo().

    So I guess I am to assume by default it should be switched on with my oneandone.co.uk account

    If that isn’t the problem – I’m still unsure why the fancy permalinks aren’t working for me

    I don’t believe that phpinfo(); displays the status of mod_rewrite (at least it doesn’t in my setup where it is turned on).

    BTW, after you resolve things, it’ll be a good idea to remove or at least protect files with phpinfo calls as it gives away a significant amount of info.

    When you get WP to recreate the .htaccess file from scratch, does it get created and written with access rules?

    If I delete the .htaccess file currently in my blog directory (using WS_FTP PRo program), and then go to:

    Options > Permalinks

    and then I put the following into the top box for Structure:

    /%year%/%monthnum%/%day%/%postname%/

    and then I click the ‘Update Permalink Structure’ button at the bottom

    It shows up in WS_FTP Pro as a new .htaccess file

    I check the CHMOD for this new file .htaccess file and it is 644

    So then I change this CHMOD to 755

    but the links are still not working?
    getting a 404 error still when I click on :

    http://www.jimhobbs.com/blog/2005/03/28/test2/

    Can you make a copy of the .htacess file named “htaccess.txt” and put it in your blog root so we can see the generated rules?

    http://www.jimhobbs.com/blog/htaccess.txt

    (btw thanks for the help guys … really appreciate it)

    The rules look okay, and the URL as it would be rewritten into a query string (http://www.jimhobbs.com/blog/index.php?year=2005&month=03&day=28&name=test2&page=) works fine when loaded directly. This makes me think the rewrite rules aren’t happening. Tell you what, you have FTP access, right? Go into your administration interface, manage files, and edit the .htaccess. Right after the RewriteBase line just enter some garbage…

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    lijlsijglijlsijegli

    Then try to load a page. If you get a 500 Internal Server Error, the mod_rewrite is active, otherwise it ain’t. If it is, use FTP to delete that .htaccess and write out another one using WordPress. If it isn’t active, we’ll figure that out when we get there.

    I went into the admin poart of WP

    then Manage > Files

    and then typed in .htaccess at the bottom of the page to load the .htaccess file

    Then I added the line you suggested
    lijlsijglijlsijegli
    to the file and then clicked on the update button

    Straight away I got the 500 error in the admin area itself?

    error 500: Internal Server Error

    The server encountered an unexpected condition which prevented it from fulfilling the request.

    However the URL:
    http://www.jimhobbs.com/blog/
    loads up fine

    but when I try the entry link:
    http://www.jimhobbs.com/blog/2005/03/28/test3/
    it responds differently to before… it now

    before I was getting a 404 error

    now I get 500

    interesting…..

    Well, if you put the line where I suggested, I believe that indicates the rewrite rules are active (yes, I expected the admin to misbehave). Note that I get a 500 on loading your base blog URL which I would expect. Go ahead and delete that .htaccess file from your FTP program so you can get back in.

    I’m at a loss at this point.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘mod_rewrite problem (my host is oneandone.co.uk)’ is closed to new replies.