Support » Installing WordPress » mod_rewrite on, some pretty permalinks work some don’t

  • This is related to the many permalink freakout posts I’m seeing here. I’m going to attempt to outline my 4 days of note-taking to see if someone else has an idea of how to deal with this.

    Here are the facts :

    — Both 2.5 and 2.5.1 are having permalink issues on only ONE of my many WP sites, almost all on Dreamhost; this particular site is on a different DH server from the others which work just fine after upgrade to both 2.5 and 2.5.1.

    — After upgrade, nearly all permalinks, which remained set to Day/Name (, failed to work, defaulting to index.php and not using page.php. Not only top-level pages failed, but all sub/childpages in the main menu. These pages are linked via an unordered list that is hard-coded into the header template (i.e. “/permalink” or “/parent/permalink”).

    — Any wp_list_categories instances were completely non-functional.

    — I have verified the .htaccess file and site index.php (at root level but referring to the site which is in a subdirectory). WP writes perfectly to it. I also tried going back to having full site URL reflect the subdirectory and no go.

    — I installed AskApache RewriteRules Viewer 3.0 and looked at this info and all appears good to me (as far as mod_rewrite being active, etc.).

    — I then switched to default permalinks and this works but of course all internal links are now non-functional.

    I tried changing to default theme and voilĂ , original, Day/Name permalinks work, so I carefully compared header/footer code to be sure my theme doesn’t have something questionable (it worked perfectly up to now) and cannot find any reason why it and the page.php are not working. I have no sidebar widgets nor dynamic widgets code in sidebar file.

    — I tried shutting off all plugins and reactiving one by one. Doesn’t change anything.

    — After the upgrade, one page, which used a custom template, continued to work, including its childpages that display as a submenu on the page. When I cloned this page template and attempted to use it for other pages that were not working, it wouldn’t function at all, defaulting to index.php. And when I click on a page to go there, even though it defaults to index.php, it shows the correct permalink (maybe this is normal?).

    — I have temporarily created a completely separate template for all parent pages using Improved Include plugin, which works, however I am stuck with having to create an awful lot of custom templates!

    — I am suspicious that there are issues with the upgrade and the database; I’ve taken a peek at it and nothing has jumped out at me but I’m not an expert in MySQL. I had a previous upgrade, to 2.3 I think, cause many problems with page becoming posts, which I fixed manually without any real problems following that incident, but I’m wondering if something else went awry that I’m not aware of…

    — Weirdness note : At one point, one of the pages showed a “Page slug” option down with the “Page template” and “Parent page” options in WP Admin but then it went away after logout/login.

    Suggestions? I would reinstall but I’m concerned that if the DB is the problem, I’ll just be duplicating the mess. Help!

Viewing 1 replies (of 1 total)
  • Here’s the summary as I read it… correct me if I’m wrong.

    1) the default theme works perfectly after the upgrade, permalinks and all.
    2) your preferred theme does not.
    3) you suspect things other than the theme.

    Let me lay this out as strongly as I can. If all other things are equal, that is, all the plugins are still active, the wordpress files are the same, the rewrite rules identical, the server identical… and the only difference between a working blog and a dysfunctional one is the act of changing themes…

    … then regardless of whether you can see something wrong with the theme, the problem *is* the theme. Focus your efforts there.

Viewing 1 replies (of 1 total)
  • The topic ‘mod_rewrite on, some pretty permalinks work some don’t’ is closed to new replies.