Support » Fixing WordPress » mod_rewrite does not work, tried everything

  • Resolved ondercey

    (@ondercey)


    Hello,

    I have stumbled upon mod_rewrite module of Apache for my WordPress installation (v2.6.2) for LAMP but I could not figured out how to get it work. My detailed configuration is here: php_info()

    First of all, I have successfully activated mod_rewrite module.

    I activated it with this code:

    cd /etc/apache2/mods-enabled
    sudo ln -s ../mods-available/rewrite.load ./

    and checked if it has been installed with this

    a2enmod
    rewrite

    Secondly, I have followed the guide “http://codeigniter.com/wiki/mod_rewrite/” and got into apache2 configuration file which stays in “/etc/apache2/apache2.conf” .. I have added these lines for making sure of my .htaccess file’s guideness is accepted by apache.

    <Directory “/var/www/html”>
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Deny from all
    </Directory>

    Third, I have created a writable .htaccess file to let WordPress engine write its own htaccess itself. I have checked it several times and I am sure that it is right in right shape. Which is: (my wordpress installation is in the root of the server)

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    After that I was expecting to see the sweet permalink structure of the WordPress which is relies on the mod_rewrite module but sadly I got “Not found” error for permalink URL’s.

    Double checked everything I did and decided to try last thing for it. I have added this line to my apache2 configuration file;

    LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so

    I have restarted apache after every step to see if something changed.
    The big sad problem is I still can not use permalink structure.. mod_rewrite does not work at all..

    Please help.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘mod_rewrite does not work, tried everything’ is closed to new replies.