Support » Plugins and Hacks » mod_pagespeed issue with WP Super Cache

mod_pagespeed issue with WP Super Cache

  • Hey there,

    WP Super Cache is causing troubles on two of my WordPress installations. On one the site just stops loading (digitalesgrundrauschen.de) and the other one doesn’t load at all (macosxscreencasts.com).
    I’ve turned the plugin off as an interim solution.

    What information do you need to resolve this bug?

    Thanks very much,

Viewing 6 replies - 1 through 6 (of 6 total)
  • if you go into the advanced settings for wp super cache, and look for the “Compress pages” setting, uncheck that and it should begin working again. More information here: http://andrewpeng.net/posts/2010/11/07973-mod_pagespeed-and-wp-super-cache-issues.html

    Plugin Author Donncha O Caoimh


    Zettt – You could also use the debug system in the plugin to figure out what the plugin is doing.

    You’re right! That actually helped. However though, after deactivating that option I have the problem that the settings page for WP Super Cache stays empty. If I disable mod_pagespeed everything’s back to normal.

    Got it. Somehow I had Legacy Caching activated. oO I don’t know why…always had mod_rewrite on. Seems like after re-enabling WP Super Cache it defaults back to Legacy.

    Sorry. That was wrong…

    I meant: Sorry, I was wrong. It didn’t help.

    Plugin Author Donncha O Caoimh


    I tried mod_pagespeed this morning and it broke my site when I had compression enabled. When I disabled compression in WP Super Cache and cleared the cache I was able to serve pages off my site.

    The pagespeed docs say that the mod doesn’t compress pages but it does seemingly load mod_deflate and compress pages. I don’t know if mod_pagespeed caches the compressed pages however.

    Right now, I’d say avoid mod_pagespeed and use wp-super-cache with compression, wp-minify to minify, and OSSDL CDN off linker to use a CDN if necessary.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘mod_pagespeed issue with WP Super Cache’ is closed to new replies.