WordPress.org

Support

Support » Plugins and Hacks » Facebook » [Resolved] mod_fcgi execution timeout

[Resolved] mod_fcgi execution timeout

  • Hi All,

    I’m getting mod_fcgi execution timeouts when I try to input my App ID & secret.

    My server runs Virtualmin on Debian 6. The error logs show:

    [Mon Jan 07 08:10:36 2013] [warn] [client 124.150.47.101] mod_fcgid: read data timeout in 31 seconds, referer: http://mydomain.com/wordpress/wp-admin/admin.php?page=facebook-application-settings
    [Mon Jan 07 08:10:36 2013] [error] [client 124.150.47.101] Premature end of script headers: options.php, referer: http://mydomain.com/wordpress/wp-admin/admin.php?page=facebook-application-settings

    My google-fu turns up a bunch of posts (none relating to this plugin) which just say to increase maximum fcgi script exec time, which I’ll try, but I can’t really see why this plugin would need to run for more than 30 seconds.

    Any thoughts about what might be causing this? / How I can fix it?

    http://wordpress.org/extend/plugins/facebook/

Viewing 1 replies (of 1 total)
  • Actually, extending the fcgi timeout worked.

    For others reading this, in virtualmin:
    “Server Configuration” > “Website Options” > “Maximum PHP script run time” > set to 300 seconds.

    May want to change it back to 30 after you put in your APP ID & secret.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] mod_fcgi execution timeout’ is closed to new replies.
Skip to toolbar