Support » Theme: GeneratePress » Mobile view broken on data but works fine on wifi.

  • Resolved Joanzin

    (@joanzin)


    Hello
    I am.having an issue with my mobile view of the website. It works fine on wifi in mobile view but if you turn off the WiFi and use the phones data the view is all out of whack. The header image doesn’t shrink to the mobile view size and the menu is jacked up. Also…I have noticed images don’t want to load unless I use jetpack photon. The one image at the top of content won’t load no matter what I do and there is a skip to content link at the top of the page. I have disabled all plugins and it still seems to have issues with the header image and menu. Any help would be great.
    kewlstitches.com
    Thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • If i check the site and inspect it i get this error:
    “Failed to load resource:/styleslocation/style.css the server responded with a status of 404 (Not Found)”

    maybe that has something to do with it?
    For me on a mobile the site looks normal?

    Thank you for checking but did you check it using data on your phone or using the wifi in your phone. It only does this on mobile data. It does it in mobile Firefox, chrome, and IE. Opera is fine. Hat would cause the fail to load and a 404 error? Is that something on the server?
    Thank you!

    Theme Author Tom

    (@edge22)

    I’m not noticing any differences between Wifi and data. Websites don’t actually care where the data is coming from (I’m not even sure if it could tell if it wanted to).

    Can you post a screenshot of what you’re seeing?

    Hello
    Thank you for checking this out. Here is a picture: https://ibb.co/cD4Hi5 . Please keep in mind that if you first visit the site on wifi, you must clear your cache on your mobile browser to see it how it really is on data.
    Thank you.

    Leo

    (@leohsiang)

    I’m not seeing any issues either.

    This is what I see on mobile using data and incognito mode so all caching issue is cleared: https://s28.postimg.org/odc537ibh/IMG_5503.png

    Theme Author Tom

    (@edge22)

    Do you have any caching plugins activated? They’re usually at fault when there’s inconsistent views like this.

    Hello
    I have disabled all plugins accept for the generate press premium plugin and the header banner image still looks huge in comparison to the rest of the site on my mobile data as well as the menu still looks jacked too. I think this may be my carrier causing this. What browsers did you check with? I have tried four different ones and the only one that worked was opera. Mobile Firefox, Chrome, and IE all had the same messed up view.
    I also need help with removing or fixing the skip to content link at the top of the page in mobile view.
    Thank you!

    Theme Author Tom

    (@edge22)

    Looks like you’re using Cloudflare. Try disabling Rocket Loader in your CF settings.

    Just to let you guys know you provide excellent support. But what I found out regarding this issue is that I had followed your method of using autoptimize and async to optimize the theme. Autopimize updated and broke things in the mobile view. I even tried using m daughters brand new phone and it still was getting the same view I posted for you…the broke view. I messed with all the plugins and found it was autoptimize. I tried many plugins similar and finally found fast velocity minify and because it offered more control over the scripts I found that compressing .css not only broke the mobile menu and it wouldn’t function but it also wouldn’t allow some of the styles to load. Inlining .css head and footer both and preserving the order of .css fixed everything. There is an issue with compressing both .css for speed apparently. Just thought you may want to look into this and use a different plugin for optimizing.

    I have disable rocket loader and still have skip to content showing.

    Thanks!!

    I’m sorry but i made a mistake as it was late when I wrote the above post. I meant to say JS instead of .css files. I had to inline the .css both in the header and footer and preserve the order using fast velocity minify. I also let it process JS files. It not only sped up my site a bit but it fixed things. I just wanted to clarify that. All I know is that autoptimize when it updated, broke things.
    Thanks

    kudo’s to fast velocity minify, it’s solid plugin, but I don’t understand

    All I know is that autoptimize when it updated, broke things.

    as AO has not been updated in the last 6 months?

    frank (ao dev)

    Theme Author Tom

    (@edge22)

    @joanzin, glad you got it working!

    @optimizingmatters, awesome plugin. I recommend it all the time 🙂

    Yes…I have been battling this for 6 months. At first I didn’t realize it was happening because I always had my phone on wifi. When I finally discovered it months had gone by. Then I spent months trying to figure it out. I found some people saying it was a carrier issue and others said it was a browser issue. Others even said it a plugin issue. It drove me nuts cuz I couldn’t find the right answer. And it didn’t do it on every device which was even more weird. Opera always loaded it right and so did iphone it seemed so it was very confusing. I am so happy I finally figured it out. I realized it was a real issue when my daughter brought over her brand new android phone which had never visited my site before and it did to her too. That told me it was not a caching issue as I was told here. So I pushed on and worked on it til I couldn’t see straight and finally figured it out. But thanks for all of your help. You guys are great!! Yo may want to keep this in mind to help others.
    Thanks!!

    Theme Author Tom

    (@edge22)

    Appreciate you reporting back 🙂

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Mobile view broken on data but works fine on wifi.’ is closed to new replies.