Support » Fixing WordPress » Mobile version loads forever

  • Hello there!
    I am having issues with the mobile version of my site… let me explain…

    I use avada for the site and it works ok on desktop but on mobile it simply keeps loading and loading and nothing happens… I backup my site using a migration plugin and edit my site in a different domain…

    So my main domain is domain1.com this is my live site so I dont do updates there, I do them on domain2.com which has the same setup and lives in the same server…. if I go to domain2.com on my mobile it works, on desktop works and everywhere else… please keep in mind that domain1.com and domain2.com are the exact same site… so once I finish editing my site on domain2.com i export it and upload it to my wordpress living in domain1.com (which is my live site) so… why would the same site work on domain2.com (mobile/desktop) but not when using domain1.com (only works on desktop), does it have anything to do with the actual domain name?

    Any help is appreciated.
    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • There could be a number of reasons why two sites with seemingly the same content on the same server could be behaving differently, and usually it’s because as much as we try to make sure a plugin or our copy method copies everything, it is possible it misses something small but very important for this specific mobile functionality. There could also be a setting that differs between the two domains’ hosting settings or PHP/user settings.

    It would help us help you if you could provide the real domain names if they’re both publicly accessible and you’re willing to share for us to test on our own desktop and mobile browsers.

    The first thing I recommend checking is to compare .htaccess files on the two sites if you have them. Modification of desktop and mobile browser behavior can often be found there. Make sure there are no differences between the two files.

    Thanks, unfortunately, I cannot post the links because they belong to the company I work for and I need authorization to do that, so I followed your advised and checked the .htaccess file, and they were different but with good reason…

    domain1.com .htaccess file had Rewrite Base //
    domain2.com .htaccess file had Rewrite Base /2/ this is because I installed WP in domain2.com/2 so thats why it showed up like that.

    So at this point I figured it was something related to installing it in the root directory… so I did install it in domain2.com and it didnt work either… it works if I install in any directory other than the main directory… my work around was to install in a directory and then put an index file redirecting visitors to the folder where I installed WP.

    A fresh install of WP has the same thing “rewrite base //” and it does work on mobile so my guess is something is wrong with my static home page…

    any thoughts?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Mobile version loads forever’ is closed to new replies.