WordPress.org

Forums

Dynamic Widgets
[resolved] Mobile v Desktop (6 posts)

  1. andy987
    Member
    Posted 9 months ago #

    Hi
    I would love to show one widget for Mobile and a different one for non-mobile devices.

    That means I need the ability to hide a widget on mobile devices, which I can do. I also need the ability to show a widget only on mobile, and this is what I cannot do.

    regards

    Andy

    https://wordpress.org/plugins/dynamic-widgets/

  2. Qurl
    Member
    Plugin Author

    Posted 9 months ago #

    Use the latest developemnt version (beta). It has this feature.

  3. old310guy
    Member
    Posted 9 months ago #

    Dynamic Widgets 1.5.7 is not working at all. Word Press is version 3.9.1. PHP version is 5.3.7. Theme is Ink Themes "Geocraft" with Dynamic Widgets in sidebar enabled for all pages. wp_head() check: wp_head() is called. I have installed, deleted, and reinstalled several times. According to the InkThemes forum, Dynamic Widgets should be working in "Geocraft". Website is http://www.assistedliving-abroad.com. ISP is "GoDaddy". There is no problem adding additional Widgets to any of the pages; manually.
    [ email redacted, support is not offered via email ]

  4. Qurl
    Member
    Plugin Author

    Posted 9 months ago #

    It would have been easier when you would have opened a new topic as this has nothing to do with Mobile vs Desktop...

    Anyway, it's a bit hard to know what's going wrong as Geocraft from InkThemes is a premium theme. Best guess (read: most obvious problem) is that Dynamic Widgets gets 'confused' by the theme due to inclusion of several post types within one page or heavily usage of custom queries. In the latter this might be fixed by adding a wp_reset_query() before the sidebar is called.

    Also not sure what you're trying of course... Are you sure you're setting DW rules to the correct widget?

  5. andy987
    Member
    Posted 9 months ago #

    Qurl,
    Just wanted to say thanks. I have it working now.

  6. andy987
    Member
    Posted 9 months ago #

    Whoops, forgot to mark this as resolved.

Reply

You must log in to post.

About this Plugin

About this Topic