• Resolved atiq97

    (@atiq97)


    Hi, First of all a great plugin, I love the translation feature. So easy.

    I added my site in the link. The language switcher not working on the mobile version. When we click on it, it just closes the hamburger, on the click it should show flags dropdown.

    2nd, the flags are not showing on some devices. Please HELP.

    I am using.

    Astra, Astra Pro, Elementor, Elementor Pro. runnig latest php.

    Tried to change themes but no success. Same issue everywhere.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter atiq97

    (@atiq97)

    I fixed the flag issue via CSS. However, on mobile, the flag dropdown should show on click. Who click and hold the mobile menu? Visitors are not developers. I’d appericiate and thankful If you can help me.

    Plugin Author Anghel Emanuel

    (@anghelemanuel99)

    Hello there,

    I was testing your issue on my phone and it seems to be ok. I could use the flag dropdown when I click on that little arrow.

    If the problem is still there, you can put the languages into a menu item.

    If there’s anything else, please let us know!

    Best regards,

    Thread Starter atiq97

    (@atiq97)

    Hey, the issue is visitor never clicks on small arrow ( tiny arrow-like 5px width ) they always click on menu. Any possible way I can apply click on the entire menu?

    2nd thing: If I add 2 languages in the menu instead of shortcode. It displays both languages.

    For example. I visited website, click on 2nd language. So it should hide the current language and show only other flag to switch.

    Plugin Author Anghel Emanuel

    (@anghelemanuel99)

    Hello there,

    To show only the language that the user selects you need to go to Appearance -> Menus. There you need to search for “Language Switcher” then click on the little arrow from there.
    After that go to “View all” and select Current Language and add this to your menu items with your languages too and this should fix your problem.

    Here is a screenshot to help more:
    https://ibb.co/tzpwLgG

    If there’s anything else, please let us know!

    Best regards,

    Thread Starter atiq97

    (@atiq97)

    You know what? You guys are great. thankyou very much. I am new to translate press. Before I was using wpml. Thanks for solving my problem. You just earned a 5-star review

    P.s. It’ll be great if dropdown opens by clicking on entire menu ( mobile devices ) rather then clicking on small arrow.

    Thankyou so much. Please mark it as solved

    Plugin Author Anghel Emanuel

    (@anghelemanuel99)

    Hello there,

    I`m glad that I could help you.

    If you want to display the same languages in your menu, go to Appearance -> Menus, and there don’t put Armenian under the English language.

    Like this: https://ibb.co/Dk9TwN6

    Not like this: https://ibb.co/C5b1t8r

    Have a nice day.

    Best regards,

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Mobile switcher not working’ is closed to new replies.