Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Mobile swipe box freezes And other issues

  • Resolved generalnumpty

    (@generalnumpty)


    I already have many justified gallery’s on my site (not Photonic ones yet) and I have the “lightbox with Photoswipe” by Arno. Your “Swipebox bundled one looks identical.
    I have created my first Photonic masonary gallery and used your swipbox option but on mobile when I tap an image the swipebox opens and then freezes -no swipe and no buttons will work.

    The other thing I have seen is that when I open a photonic image on a PC the swipebox is working ok but as I already have “lightbox with Photoswipe” installed, that one also opens ontop of yours. I have tried different settings but can not find the right one or combo to disable the bundled one and just use the one I already have.
    I have tried “None” in the options which turns of both of them.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Sayontan

    (@sayontan)

    Sorry, I will need a URL to help you out on this one.

    I believe this would have something to do with your second lightbox plugin – you have to stop it from interfering with Photonic’s galleries in the same manner that Photonic’s lightbox does not interfere with the other plugin’s behaviour on non-Photonic photos.

    generalnumpty

    (@generalnumpty)

    Yes there does seem to be a conflict going on.
    Odd thing is that if I choose “image lightbox” from your inbuilt lighboxes then the Photonic gallery does not use that one at all but it uses my already plugged in “lightbox with Photoswipe” by Arno.

    Will that mean that the page is still running two lighbox scripts and so will cause the page to be slower or possible other upsets on different devices?.

    How can I fully disable all of the Photonic bundled ones and just use the plug in I already have.
    Is there an email address that I can send you my URL to privately

    Plugin Author Sayontan

    (@sayontan)

    Is there an email address that I can send you my URL to privately

    This is prohibited as per the forum guidelines and can get you moderated (or even banned) – I know, because I had my wrist slapped at one point of time for this.

    Odd thing is that if I choose “image lightbox” from your inbuilt lighboxes then the Photonic gallery does not use that one at all but it uses my already plugged in “lightbox with Photoswipe” by Arno.

    With any lightbox-type of a script you can make it focus on specific elements. E.g. whenever Photonic runs, it targets links with a specific class. That way it knows that it should leave alone any link that is not generated by Photonic. There is an explicit option that you can turn on wherein you can use Photonic for non-Photonic photos (Photonic → Settings → Generic Options → Generic Settings → Photonic Lightbox for non-Photonic Images) that lets you use Photonic’s lightbox for other stuff. Of course, the challenge here is when you try to use this with galleries created by other plugins because each gallery will have its own type of markup. E.g. PhotoSwipe requires a rel attribute to be set to be able to group items into the same gallery. If the rel attribute is missing, PhotoSwipe will treat each image as an individual item and not a part of a gallery.

    But, just the way that I can make Photonic target specific galleries, the provision should be there in the other script to exclude specific types of links. That is the surest way of avoiding conflict.

    Will that mean that the page is still running two lighbox scripts and so will cause the page to be slower or possible other upsets on different devices?

    Yes.

    How can I fully disable all of the Photonic bundled ones and just use the plug in I already have.

    Without any knowledge of your site I cannot say. For sure you cannot disable all of Photonic’s scripts, because that will cripple your layouts. There are several other limitations that you will face, such as being able to click on an album’s thumbnail and see all the photos within that album. This sort of specialized behaviour is bundled with Photonic.

    You can try the following:

    1. Select PhotoSwipe as your lightbox within Photonic
    2. Select the option Photonic → Settings → Generic Options → Generic Settings → Don’t include third-party lightbox scripts

    This will load Photonic’s core scripts and include all the specialized calls that it needs to make to PhotoSwipe. Your site will then rely on the lightbox from elsewhere. However, as it states on the option setting, you will have to work with the support team for the other plugin to resolve any issues at that point as it goes beyond the scope of Photonic.

    generalnumpty

    (@generalnumpty)

    Is there an email address that I can send you my URL to privately

    This is prohibited as per the forum guidelines and can get you moderated (or even banned) – I know, because I had my wrist slapped at one point of time for this.
    Sorry Newbe Here

    Select PhotoSwipe as your lightbox within Photonic
    Select the option Photonic → Settings → Generic Options → Generic Settings → Don’t include third-party lightbox scripts

    This will load Photonic’s core scripts and include all the specialized calls that it needs to make to PhotoSwipe. Your site will then rely on the lightbox from elsewhere. However, as it states on the option setting, you will have to work with the support team for the other plugin to resolve any issues at that point as it goes beyond the scope of Photonic.

    I have tested this and the other plug in is not loading and the included photoswipe one is.
    But from what I think you have said that was suposed to stop photoswipe and let the already plugged in lightbox take over.
    If I use your included swipebox with the above set up then the Photonic gallery disappears from my site.

    Yes I have seen the problems with disabling my lightbox plug in and doing this (Photonic → Settings → Generic Options → Generic Settings → Photonic Lightbox for non-Photonic Images). I have been through them all and seen that some work on pc and not with a mobile. Your description of possible issues has helped me learn.

    Plugin Author Sayontan

    (@sayontan)

    I have tested this and the other plug in is not loading and the included photoswipe one is.
    But from what I think you have said that was suposed to stop photoswipe and let the already plugged in lightbox take over.
    If I use your included swipebox with the above set up then the Photonic gallery disappears from my site.

    Umm… none of these is the expected behaviour. In fact I have just now tested using this functionality.

    If I select Photonic → Settings → Generic Options → Generic Settings → Don’t include third-party lightbox scripts, then “View source” for my page with the gallery and search for “third-party/photoswipe/photoswipe.min.js” I get no matches. The only match I can see is photonic-photoswipe.min.js, which should be included (it has Photonic’s calls without the PhotoSwipe script).

    generalnumpty

    (@generalnumpty)

    Sorry for the delay. I will re-test.

    generalnumpty

    (@generalnumpty)

    Ok a couple ot tests. If I do this while using Fancybox3 then every image over the whole of my site disappears. Photonic → Settings → Generic Options → Generic Settings → Don’t include third-party lightbox scripts,

    I am only using the photonic gallery on 1 page at the moment to test. All my other gallerys are foobox for which I am looking for a replacement.

    If I do the same but use your swipebox option then all the images over the whole site are ok and opening with the normal pluging I use. And the only lightbox working on that page IS your swipebox. BUT after visiting an image in that gallery my website menues become unresponsive.

    EDIT TO SAY -unresponsive until I refresh the page.

    I can not seem to find any combo option to get everyone to play nice

    Plugin Author Sayontan

    (@sayontan)

    If I do the same but use your swipebox option then all the images over the whole site are ok and opening with the normal pluging I use. And the only lightbox working on that page IS your swipebox. BUT after visiting an image in that gallery my website menues become unresponsive.

    If I use other Photonic bundled lighboxes then other bad stuff happens.

    This isn’t the right use of the option – that option is meant to be used only if the lightbox from Photonic you are using matches the lightbox on your site.

    Sorry, but at this point I am unable to help without a URL – deciphering this from a URL is literally a matter of minutes for me for these types of issues, but going through descriptions doesn’t give me the information I can provide to help you.

    generalnumpty

    (@generalnumpty)

    If you can stand by I will “flash it on here for 1 min and then delete.
    Thank you for your patience.

    generalnumpty

    (@generalnumpty)

    https://

    Plugin Author Sayontan

    (@sayontan)

    Your site seems to be behaving fine right now. I can see one Photonic and one non-Photonic gallery, and both seem to be getting the PhotoSwipe lightbox. I do see that the PhotoSwipe lightbox script is also included in the source data, which tells me that this option has not been set: Photonic → Settings → Generic Options → Generic Settings → Don’t include third-party lightbox scripts.

    Note that you seem to have some sort of a “lazy loading” plugin that is delaying the appearance of Photonic photos. That is liable to cause conflicts – Photonic already has such behaviour baked into the plugin (it cannot be disabled) and additional scripts can cause issues in this regard.

    generalnumpty

    (@generalnumpty)

    Sorry yes I was fiddling. I have now set Photonic → Settings → Generic Options → Generic Settings → Don’t include third-party lightbox scripts.

    But my website menus become un-clickable after looking at the gallery in lighbox until the page is refreshed.

    The firs masonary gallery on the “a test” page is a Photonic one
    Thank you for your help.

    generalnumpty

    (@generalnumpty)

    I have a plug in called a3 Lazy Load. For use on my Foo gallerys

    generalnumpty

    (@generalnumpty)

    I have disabled the lazy load plug in but still getting website menus become un-clickable after looking at the gallery in lighbox until the page is refreshed. On my a new test page. Android phone and pc.

    Also I do not now see any lazy load indications on the images as I scroll down the gallery on on the images in the photonic gallery with my lazy load plug in disabled. I tested after clearing phone cache or refreshing the pc page.

    Plugin Author Sayontan

    (@sayontan)

    But my website menus become un-clickable after looking at the gallery in lighbox until the page is refreshed.

    This is happening because there is a ghost PhotoSwipe element being left on your screen – that is not getting closed out when you exit PhotoSwipe and is acting as a transparent but non-clickable layer over your menus. Whether this is coming from Photonic or the other lightbox not being able to close out all PhotoSwipe elements (including those not created by it) I cannot say.

    As documented in the option, issues with this setting have to be dealt with by talking to the providers of your other scripts as they are beyond the scope of Photonic. I can offer some suggestions (involving a minor code change), but they are not guaranteed to work.

    You will first need to turn off minification (Photonic → Settings → Generic Options → Advanced → Script Dev Mode), then edit the file photonic-photoswipe.js (You can go to Plugins → Editor, select Photonic from the drop-down, and navigate to include → scripts → front-end → build → photonic-photoswipe.js). Go to line 733. You will see this:

    $('body').append(this.pswp);

    Comment out that line (i.e. prefix it with //).

    Save and reload. Let me know if it resolves the problem.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Mobile swipe box freezes And other issues’ is closed to new replies.