Support » Plugin: LiteSpeed Cache » Mobile Rendering Bug Triggered By Start Lazy Load Images

  • Resolved Nic Windley

    (@nisiwi)


    Hello LS Support Team.

    I’m running into a strange bug that is preventing Google Mobile crawler from rendering the home page correctly.

    Google search console shows a couple of errors which on inspection seem to be caused by an LS script relating to lazy loading.

    As I’m not lazy loading images with LS and all page optimisations are deactivated, I’m confused about what is causing this other than a JS script conflict.

    I’ve attached some images and a report number below.

    Report number: OPYMMDYC

    https://imgur.com/nLJTqFR
    https://imgur.com/wmy2sms
    https://imgur.com/Da3SxWL

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • Your images are lazy loaded by WordPress and your background-images have a transition with delay. CSS transition causes a delay effect like lazy load. Both issues are caused by your theme and have nothing to do with cache plugin.

    https://www.wppagebuilders.com/disable-lazy-load-in-wordpress-5-5/

    Thread Starter Nic Windley

    (@nisiwi)

    OK, the stack trace error says its related to LiteSpeed Lazy Load though hence why I asked the question here.

    Thanks for the hint, I’ll look into disabling the WP lazyload feature.

    • This reply was modified 3 months, 1 week ago by Nic Windley.
    • This reply was modified 3 months, 1 week ago by Nic Windley.
    Thread Starter Nic Windley

    (@nisiwi)

    I added the function to dsable WP Lazy Load without any resolution.

    I added the function to dsable WP Lazy Load without any resolution.

    You didn’t add this function. WordPress lazy load still exist:

    https://postimg.cc/xk5gRR1t

    Thread Starter Nic Windley

    (@nisiwi)

    The function was/has been added:

    https://imgur.com/a/dmgDbG7

    If I disable LS google mobile crawler has no problem rendering the home page – no errors reported.

    This only happens on the home page, no other page.

    • This reply was modified 3 months, 1 week ago by Nic Windley.
    • This reply was modified 3 months, 1 week ago by Nic Windley.

    try disable UCSS

    Thread Starter Nic Windley

    (@nisiwi)

    Its already disabled.

    All LS page optimisations apart from JS deferred are disabled.

    I have tested both with and without JS deferred and it made no difference.

    Thread Starter Nic Windley

    (@nisiwi)

    If I run the google mobile friendly test on the home using the LS page optimisation debug switch it renders without error – I.e.

    www.example.com/?LSCWP_CTRL=before_optm

    So the problem relates to page optimistion, however almost all features are disabled. CSS optimisation is completely disabled.

    • This reply was modified 3 months, 1 week ago by Nic Windley.
    • This reply was modified 3 months, 1 week ago by Nic Windley.
    • This reply was modified 3 months, 1 week ago by Nic Windley.

    Okay, this may happen because you use Elementor and with Elementor there are always issues that seem cannot be fixed. The point is that the background-image on homepage cannot be loaded, because URL from background-image will be stripped from code, but this has nothing to do width lazy load.

    Maybe Plugin Support has any ideas how to solve it.

    Thread Starter Nic Windley

    (@nisiwi)

    So, are you saying this is an Elementor issue ?

    • This reply was modified 3 months, 1 week ago by Nic Windley.

    If you disable cache plugin and the background-image is displayed again there may be a conflict with Elementor. LiteSpeed already tried to contact Elementor because some known issues can only be fixed on Elementor side, but Elementor doesn’t answer. That is what I heared about it. But again, disable or remove cache plugin temporary and check if this background-image appears or not.

    Thread Starter Nic Windley

    (@nisiwi)

    Support ticket open with Elementor. Let’s see what happens.

    This means image is not displayed if you disable cache plugin?

    Thread Starter Nic Windley

    (@nisiwi)

    I’m not convinced that it is a background image problem.

    As a further test, I duplicated the home page and created a copy of the shopfront archive as a page using the same elements and tested that using the Google mobile crawler and there were no errors.

    https://imgur.com/fvRfNus

    This looks like a bug that gets triggered only on the home page when it is an archive page. Given the error is still showing as an LS error in the stack trace I’m nor ruling our LiteSpeed as the cause, nor am I Elementor.

    Plugin Support qtwrk

    (@qtwrk)

    if you simply reset it to default , how does that go ?

    or default + mobile cache solo

Viewing 15 replies - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.