Support » Plugin: AMP for WP - Accelerated Mobile Pages » Mobile redirection Showing on Desktop

  • Hi,
    When I activate “mobile redirection” in advanced settings, I noticed that there’s also a redirection to AMP pages on desktop pages. Is there a way to disable AMP pages on desktop to make sure this setting is only applied to mobiles and tablets?
    Anyone had the same problem?
    Thanks for your help

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Contributor ampforwp

    (@ampforwp)

    Hey @stephanebeck,

    That’s really strange.

    Can you please share the URL??

    Regards
    Marqas

    Thread Starter stephanebeck

    (@stephanebeck)

    Hi Marqas,

    After having switched the “mobile redirection” setting to OFF 2 days ago, and back ON yesterday (24h ago), it’s the opposite behaviour I now get: no more auto-redirection to AMP!

    As of now, on the following AMP, the internal links (links to the same optiderma.com domain) are not redirecting to their AMP counterparts:

    https://www.optiderma.com/articles/best-antifungal-foods-anti-candida-diet/amp/

    I’ve cleared browser cache, as well as ClouldFlare cache.

    Thanks,
    Stéphane

    Thread Starter stephanebeck

    (@stephanebeck)

    After having switched the “mobile redirection” setting to OFF 2 days ago, and back ON yesterday (24h ago), it’s the opposite behaviour I get now: no more auto-redirection to AMPs!

    As of now, on the following AMP, the internal links (links to the same optiderma.com domain) are not redirecting to their AMP counterparts (except the related posts):

    https://www.optiderma.com/articles/best-antifungal-foods-anti-candida-diet/amp/

    I’ve cleared browser cache, as well as ClouldFlare cache, but it still doesn’t seem to work…

    Thanks,
    Stéphane

    Thread Starter stephanebeck

    (@stephanebeck)

    Still not working. Any idea?

    Thanks,
    Stephane

    Plugin Contributor ampforwp

    (@ampforwp)

    Hey @stephanebeck,

    Have you updated the plugin to the latest version?
    We have resolved the redirection issue in our latest update.

    Please update the plugin and let us know if that solves your problem or not.

    Regards
    Marqas

    Thread Starter stephanebeck

    (@stephanebeck)

    Thanks for your answer,

    My plugins are set on auto-update and I’m running version 0.9.53 of your plugin, which appears to be the latest version, am I right?

    However, the auto-redirect toward AMP versions of posts seems to be kinda random. If you visit our homepage (https://www.optiderma.com/amp/) you’ll see that some links are auto-redirecting and some don’t. Ans it seems to change from one day to another (it’s been 3 days that I’m monitoring it).

    Anything else I can do to improve that “redirection rate”?

    Thanks,
    Stéphane

    Plugin Contributor ampforwp

    (@ampforwp)

    Hey @stephanebeck,

    Can you please contact us at team@magazine3.com? There is a limitation of help here.
    If you can contact us through email, I will personally look into it.

    Hope you can understand our concern.

    Regards
    Marqas

    Thread Starter stephanebeck

    (@stephanebeck)

    Sounds good Marqas, thanks.

    Plugin Contributor ampforwp

    (@ampforwp)

    Hey @stephanebeck,

    Have you updated the plugin?

    Please update the plugin to the latest version and let us know if you are facing any more issues.

    Regards
    Marqas

    Thread Starter stephanebeck

    (@stephanebeck)

    Thanks for following up Marqas,

    Yes, plugin updated to its latest version (0.9.54.2, as of today)

    The redirection behaviour is super random and seems to change every day. It’s frustrating to have absolutely no control over it.

    As of right now (and it may be different in 30 min.) the following page redirects to its AMP version while viewing from a desktop, which isn’t normal:

    https://www.optiderma.com/articles/essential-oils-for-fleas-dogs-cats/

    Cheers,
    Stéphane

    Plugin Contributor ampforwp

    (@ampforwp)

    Hey @stephanebeck,

    Are you removing category base? If yes, then that might be the cause of this issue.

    Let me know so that I can give you a better solution.

    Regards
    Marqas

    Thread Starter stephanebeck

    (@stephanebeck)

    Not 100% sure but if you’re talking about AMP › Getting Started › SEO › Advanced Index & No Index Options › Categories… then it is set on “index”

    Thanks,
    Stéphane

    Plugin Contributor ampforwp

    (@ampforwp)

    Hi @stephanebeck,

    I am talking about your normal website not AMP, are you removing the category base for your normal website?

    Regards
    Marqas

    Thread Starter stephanebeck

    (@stephanebeck)

    Sorry for the late reply.

    I’m still having the same redirection issue upon update of the AMPforWP plugin to its 0.9.59 version.

    My permalink structure is: http://www.optiderma.com/%category%/%postname%/

    The category base is: skin-health

    The tag base is by default (empty)

    What can I do to get this AMP redirection working properly?

    Thanks,
    Stéphane

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Mobile redirection Showing on Desktop’ is closed to new replies.