Support » Plugin: LiteSpeed Cache » Mobile page speed still slow

  • Resolved healthinnovations

    (@healthinnovations)


    Hi guys,

    hope you’re having a good weekend. I’m posting as my desktop site is loading great, it’s the fastest it’s ever been but my mobile site page speed is still slow.

    When I check my site kit it gives the following readings:

    Mobile site loading:

    https://snipboard.io/tTsqzY.jpg

    Desktop site loading:

    https://snipboard.io/TPGByC.jpg

    I have mobile cache and guest mode turned on but other than that the desktop and mobile site are using the same settings. I am minifyinh all CSS and JS. I am generating UCSS. Can you tell me what the issue is?

    Thank you.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    the image links are not loading , please verify

    and meanwhile , please also provide the report number , you can get it in toolbox -> report -> click “send to LiteSpeed”

    Best regards,

    Thread Starter healthinnovations

    (@healthinnovations)

    Hi guys,

    hope you’re having a good weekend. I’m posting as my desktop site is loading great, it’s the fastest it’s ever been but my mobile site page speed is still slow.

    When I check my site kit it gives the following readings:

    Mobile site loading:

    https://snipboard.io/4qDX3W.jpg

    Desktop site loading:

    https://snipboard.io/ey5Sfc.jpg

    I have mobile cache and guest mode turned on but other than that the desktop and mobile site are using the same settings. I am minifyinh all CSS and JS. I am generating UCSS. Can you tell me what the issue is?

    Thank you.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    yes, but please provide the report number first , you can get it in toolbox -> report -> click “send to LiteSpeed”

    I will need to go through some configuration check first

    Best regards,

    Thread Starter healthinnovations

    (@healthinnovations)

    Report number: TTECWRNY

    Report date: 10/19/2021 09:35:21

    Thank you

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    in General -> below guest mode option , there is an option called guest optimization , please enable that , purge all , then check again

    Best regards,

    Thread Starter healthinnovations

    (@healthinnovations)

    Hi,

    will leave this running until morning to see if the images load OK. Also, the plugin doesn’t appear to be creating any Critical CSS. I have not had any to purge since installation. Have I missed something?

    Thank you

    Thread Starter healthinnovations

    (@healthinnovations)

    Hi,

    Images are now not loading on the desktop site in guest optimization mode: https://snipboard.io/qPujYB.jpg

    I’m expecting this to happen on the mobile site. I’ll give it another hour.

    Thank you

    Plugin Support qtwrk

    (@qtwrk)

    okay , I see , it’s your other caching layer have conflict with guest mode

    x-nananana: Batcache-Hit

    you need to disable or remove this caching layer

    I remember I have seen this before ?

    Thread Starter healthinnovations

    (@healthinnovations)

    Yes, that’s correct. There is no way to turn off this caching layer for the whole site only for certain pages.

    Plugin Support qtwrk

    (@qtwrk)

    only for certain pages.

    if the disabling allows wildcard or partial match , you can use something like / or * to exclude all pages

    Thread Starter healthinnovations

    (@healthinnovations)

    As my site is on wordpress.com, wordpress would be the ones disabling this cache. They have advised it can only be disabled for certain pages.

    Thread Starter healthinnovations

    (@healthinnovations)

    The mobile site has just gone down. I’m going to turn GM off now.

    Thank you

    Plugin Support qtwrk

    (@qtwrk)

    how does it disable ? do you have control over it or something ?

    Plugin Support qtwrk

    (@qtwrk)

    just found this https://pressable.com/knowledgebase/how-to-prevent-batcache-page-caching-on-pressable/

    so if you can edit wp-config.php

    try add this line

    if (strpos($_SERVER['REQUEST_URI'], "/") !== false && $batcache ) {
      $batcache->max_age = 0;
    }
    Thread Starter healthinnovations

    (@healthinnovations)

    Hi I’m getting a “Submitted URL blocked due to other 4xx” issue warning on Google Console and Quic.cloud is asking me to update NS.

    https://snipboard.io/b71iTv.jpg

    What should I do please?

    Thank you

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.