Support » Theme: WP-Forge » Mobile Off-Canvas: Menu not showing up

  • Resolved szerner

    (@szerner)



    Hi there,

    I can’t convince my wp-forge child theme to show the “hamburger icon” and title, when the option “Use Mobile Off Canvas” is enabled. When the page loads, for a fraction of a second the menu bar with icon and title is visible but then hidden again. This even happens when I directly activate the original wp-forge theme (Version: 6.4.3.3), so this supposedly is not an issue with my child-theme.

    I tested it with different browsers on my Win10 machine: Chrome, Firefox and Edge
    + Chrome on my Android phone. I also tried it together with different (non mobile) “Top Bar Positions”.

    It’s a local project, so I can’t provide a link to it for now.

    Any hints how to solve this? Do I need any other option turned on or off?

    Thank you!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Theme Author Thomas

    (@tsquez)

    Hi there,

    Thanks for choosing WP-Forge and you are correct…it has nothing to do with the child theme.

    I just tested the latest version, 6.4.3.3, locally and on the demo server: https://themeawesome.com/themes/wpforge/

    Both have “Use Mobile Off Canvas” enabled and both work fine. Seeing as how I cannot look at what you are doing or what you have installed locally, I really can’t begin to offer any hints on exactly what to do.

    You do have a menu assigned to the Main Menu area correct? What about plugins? Have you tried to deactivate any and all plugins to see if maybe one of them is causing the issue?

    What software stack are you running, WAMP, XAMP? What version of PHP are you running?

    I am currently running php 7.2.7 when I develop locally and I use MAMP

    That’s about the best I can do amigo. Sorry. If you need anything else, please feel free to ask and I’ll do my best to assist.

    Keep Being AWESOME!!!

    Hi @tsquez,

    thank you (again) for your assistance, it is very appreciated!
    I deactivated all plugins for testing purposes with no effect on my issue.

    I am developping locally with XAMPP and PHP v7.1.11. Your demo site has no issues for me either, so it must be something with my server or wordpress setup.

    I will investigate further and be back with my results (if any).

    Stephan

    Theme Author Thomas

    (@tsquez)

    Not a problem, anytime. Seems odd that its doing that. Have you tried clearing your cache?

    Sometimes when things don’t work right, thats what I have to do and then stuff starts working again.

    And yes, please let me know what you find, it could be useful to someone else experiencing the same problem.

    I’m developping with chrome developer tools, where the browser cache is allways disabled (Network>Disable cache). So no cache problem.

    The problematic title bar element

    <div class ="title-bar hide-for-large">...

    has a width and height of ‘auto’, whereas in your demo site that same element has concrete dimensions…

    I just downloaded a fresh new copy of ‘wp-forge’ theme, but no effect. I think I will have to upload the site to my testing server and see if it makes any difference.

    Theme Author Thomas

    (@tsquez)

    OK I was gonna ask you to switch to the WP-Forge theme, set the options for the menu and see if the menu shows up…if it does, then there is something wrong with the child theme.

    Let me know how it goes please…thnx.

    That’s what I did first of all, please see my entry post.

    But don’t mind, if it doesn’t work on my server, I will stick to the standard mobile menu, it’s for a very low budget project and not worth spending hours of time for debugging.

    Thanks.

    I’m experiencing the same problem here.

    Running a live/hidden for development purposes WordPress 4.9.8 with WP-Forge 6.4.3.3.

    Have done the following though the off canvas mobile menu button will still not appear properly:
    – Disabled all plugins.
    – Set the theme to WP-Forge rather than Starter.
    – Changed from PHP 7.0 to PHP 7.2.
    – Reinstalled/overwritten WP-Forge 6.4.3.3.
    – Used Firefox and Google Chrome on Linux. Cleared cache. No change. Also tested on Android / Firefox.
    – Changed the menu in Customizer. Standard mobile menu works, offcanvas does not.
    – Checked that the menu is assigned to the correct location.

    The WP-Forge demo website that you linked is working correctly.

    Any assistance would be greatly appreciated. Thank you.

    • This reply was modified 2 months, 1 week ago by  Dominiko.
    • This reply was modified 2 months, 1 week ago by  Dominiko.
    Theme Author Thomas

    (@tsquez)

    Hi there,

    I don’t know how much assistance I can provide when I cannot access the server or the site. Is this locally or is it on a remoter server?

    As you know the demo site is working fine and it is using the same theme version that you are. There is nothing fancy set up on the server.

    Other than that there is nothing much I can do guys…sorry.

    P.S.
    Sorry for the edit, was going to ask if you had the same issue with previous version 6.4.3.2…try a the previous version and see if it works https://github.com/ThemeAwesome/wp-forge/releases

    • This reply was modified 2 months, 1 week ago by  Thomas.
    • This reply was modified 2 months, 1 week ago by  Thomas.

    I managed to show up the off-canvas menu bar by adding

    .off-canvas-content .title-bar {
    	display: inherit;
    }

    into my style.css. By default it was on display: none;.

    The only issue remaining is that now the off-canvas button.close-canvas overlaps with my first button.submenu-toggle.

    • This reply was modified 2 months, 1 week ago by  szerner.

    Hm, there seems to be an inconsistency with the theme’s style.css. The style.css from the demo server lacks the problematic statement

    .title-bar {display:none}

    wheareas the official themes style.css (also on github) has this line included.
    So the demo server doesn’t have this issue, the installable theme does.

    • This reply was modified 2 months, 1 week ago by  szerner.
    Theme Author Thomas

    (@tsquez)

    Hi there,

    yes you are correct. So let’s do this, let’s remove .title-bar {display:none} and I will make sure it is removed for the next update.

    Thanks for finding this…I have been hitting my head against the wall all morning trying to figure it out.

    Good find 😉 – Thanks again.

    Theme Author Thomas

    (@tsquez)

    Actually guys I’m an idiot…seriously.

    I just went in to remove that particular css from the style sheet and it wasn’t there. So I looked at the changelog in the github repository I have locally and this is what I see:

    * Corrected an issue where the Off Canvas menu was not displaying for mobile view. This was due to some css I added, however I have removed the css and now the Off Canvas menu displays as it should in mobile view.

    Grrrr – Seems I was going to release this as part of the Foundation for Sites 6.5 update from Zurb that hasn’t happened yet. I should have looked at that before hand. My apologies. I will bump the version to 6.4.3.4 to push this out as quickly as possible.

    Thanks again guys for the catch…especially when the dev is such a dunder head 🙁

    Theme Author Thomas

    (@tsquez)

    Just pushed out the update to WP-Forge, you should see it shortly.

    Thanks again guys you are AWESOME!

    Dominiko

    (@dom-verde)

    These things happen. Thanks a lot for your prompt help with this, to y’all.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.