Support » Theme: Frontier » mobile menus not working

  • Resolved williefunk2000

    (@williefunk2000)


    Hi There!

    I cannot seem to get the mobile menu to work with the Frontier theme.

    When viewed on my PC everything is just fine, but, if I view the site on my phone or any phone, all I see are the menu ‘lines’. If I click on them nothing happens.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter williefunk2000

    (@williefunk2000)

    I found this but in the documentation but it does not seem to help! Someone musy kow what is going on here!

    The solution is to simply create a null parent menu item, one that doesn’t have a link. You’ll have to add your menu item using the custom Links option as seen below. You won’t be able to click the Add to Menu button without a valid url so you’ll have to temporarily add one which you can remove once the Menu Item is added.

    After clicking on the Add to Menu button, the new item is added on the right side of the page where it is added to the rest of your menu items. You can now delete the URL’s value.

    Alternatively, you can input a number sign ( # ) on the URL field instead of a temporary link before clicking the Add to Menu button and you don’t have to delete it later. But an empty URL field is preferable since leaving a number sign ( # ) on the URL field will move the focus to the very top of the page when the menu item is clicked or tapped.

    Theme Author ronangelo

    (@ronangelo)

    Your website seems to be down. I can’t visit to see what’s going on.

    Thread Starter williefunk2000

    (@williefunk2000)

    So Sorry! I’m a dummie!

    Here is the site for real site!

    http://chateauglass.com/

    Sorry! Thanks in advance for the help!

    Theme Author ronangelo

    (@ronangelo)

    Go to the theme’s options page.
    Display -> Main Menu. Make sure “Drop-down” is selected then click save (click save anyway even if the correct value is already selected).

    Make sure to refresh your caching plugin anytime something is changed. Even better to turn it off while you’re testing the site.

    If this doesn’t make any difference then I guess a file has been edited either header.php or functions.php or both.

    Thread Starter williefunk2000

    (@williefunk2000)

    Interesting,
    It was set to drop-down so I changed it to stacked, saved, then changed it back to drop-down and now it works!

    Thanks!
    Willie

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘mobile menus not working’ is closed to new replies.