Support » Theme: Go » Mobile Menu & Search Icon Not Working

  • Resolved joelyb16

    (@joelyb16)


    Hi,

    I’ve just created a new site with the GO theme. Unfortunately, I’ve found that the mobile menu button to drop down the navigation doesn’t work, nor does the search icon even when viewed on desktop.

    I have tried using the Console inspector tool to see if there are any errors present but it’s showing none.

    I have tried updating to the latest version of PHP which did nothing to fix the issue.

    I have also tried installing the jQuery Migration plug-in to see if it’s to do with the WordPress version I’m on (5.5) as I’m aware that some sites have run into issues with this latest update, but to no avail.

    Any help would be greatly appreciated!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi @joelyb16,

    Thanks so much for reaching out!

    I tested this on my test site, and both the search icon and the dropdown menu are working fine, as you can see below:

    Search: https://prnt.sc/u7nfss
    Menu: https://prnt.sc/u7nflz

    Could you please confirm that all of your plugins, and your Go theme, are up to date?

    If they are, then please try deactivating all of your plugins, and testing again. If the issue is gone, then please try re-activating the plugins one by one and testing after each, to find which plugin is conflicting with the Go theme.

    Please let me know if you find the conflict.

    Hi @gdalex,

    Thanks for getting back to me.

    My theme version is 1.3.5.

    I have tried deactivating all plug-ins one by one and the issue still persists.

    @joelyb16

    Did you download the theme from here on WordPress.org? It doesn’t look like the proper scripts are being enqueued.

    There is a frontend.js file that should be loaded, but if you check on your site it’s just not there. The file should be contained in the dist directory of the Go theme. /wp-content/themes/go/dist/js/frontend.js.

    There is only one check there that would prevent the script from loading. The check is if the site is being viewed via AMP. Have you written any custom code? Is this a child theme? I can’t think of a reason that the theme wouldn’t be loading the essential files.

    Evan

    @eherman24

    I activated the theme straight from my GoDaddy account instead of directly through WordPress.

    The only custom code I have written is for styling on the blog page whereby I created a copy of content.php, added some alterations and then linked the copy to the index.php file.

    I haven’t done anything related to AMP.

    It’s not a child theme.

    If I manually added frontend.js would this likely resolve the issue and if so, how would I go about acquiring the script?

    • This reply was modified 2 months, 4 weeks ago by joelyb16.

    @joelyb16

    If you revert the changes to that index.php file, do things fix themselves?

    @eherman24

    Unfortunately, no.

    @joelyb16

    Did you make any changes to the footer? The scripts are enqueued in the themes footer.

    @joelyb16

    You’ll want to make sure that you have the following in the footer.php file.

    <?php wp_footer(); ?>

    Here is the original footer.php file from our GitHub repo as a reference: https://github.com/godaddy-wordpress/go/blob/master/footer.php#L16

    It’s recommended if you are going to make customizations that you create a child theme and make all the changes there. When we release a new version of Go, the changes that you’ve made to the themes core files are going to be removed/reverted.

    https://developer.wordpress.org/themes/advanced-topics/child-themes/

    @eherman24

    That did the trick!

    I removed this line of code from the footer.php earlier today because I was trying to get rid of the WordPress stamp.

    Unfortunately, I didn’t make a back up of it before I made the change so I didn’t know what the code was or where it should’ve gone once I found out that it didn’t have the desired outcome so I just left it.

    I’ll definitely be taking your advice to make a child theme.

    Thank you so much for you help!

    @joelyb16

    Great! No problem at all. Glad that I was able to help track down the issue for you. Feel free to open up a new thread if you encounter any other issues.

    Have a wonderful weekend!

    Evan

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.