Support » Theme: Ultra » Mobile Menu on ipad

  • Resolved terry777

    (@terry777)


    I just noticed that the mobile menu on the ipad no longer shows the 3 lines, but just a box instead. I checked Safari, Edge, Chrome, and Firefox and they all show the same. Also, on my desktop, if I re-size the window down, it shows a code (F0C4??) rather than the “hamburger” menu.

    WordPress 5.2.1, Ultra 1.3.6

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 23 total)
  • Theme Author Andrew Misplon

    (@misplon)

    Hi Terry 🙂

    Good to hear from you. I’m away from my computer today. I’ll take a look ASAP and come back to you with a solution. Chat then.

    Cheers

    Andrew

    Thank you!

    I just noticed that the “back to top” icon on both my desktop and ipad is also showing a code of some sort. It works, but displays incorrectly.

    Theme Author Andrew Misplon

    (@misplon)

    The Ultra Font Awesome file isn’t being loaded. Beaver Builder is loading two Font Awesome files but the handles are different so I’m not sure why the Ultra Font Awesome file isn’t be loaded. If you wanted to troubleshoot the issue, temporarily deactivate all plugins and check for a working baseline then reactivate your plugins one by one until the issue happens again. I’m away for the weekend and Monday so, unfortunately, can’t dive into this until Tuesday morning should you need technical assistance like a custom loading for Font Awesome. The steps advised above would help you locate the source of the issue.

    I checked other sites I have using the theme, and of 5, one more is also displaying incorrectly. It doesn’t seem to matter what page builder. On this one I use Beaver Builder, but on the other that is incorrect, it’s SiteOrigin. I can’t see any difference in the source code.

    Theme Author Andrew Misplon

    (@misplon)

    To isolate the issue on the site mentioned. Temporarily deactivate all plugins and see if you can find a working baseline.

    Ok, will do on off hours, and let you know what I find. Thanks. Enjoy your weekend!

    Theme Author Andrew Misplon

    (@misplon)

    Super, let me know how it goes.

    The theme’s Font Awesome file is missing, deactivating all plugins would be a good place to start looking for a working baseline. If there are any caching/optimizations plugins in use, please clear them before deactivation. Hopefully, a working baseline can be found.

    Thanks 🙂 Chat soon.

    Where should the file be, and could I try replacing it, or is it something that is generated on the fly?

    Hmm, both sites are hosted by godaddy, which has their own caching.

    Theme Author Andrew Misplon

    (@misplon)

    The file is enqueued from the theme’s functions.php file as follows:

    wp_enqueue_style( 'font-awesome', get_template_directory_uri() . '/font-awesome/css/font-awesome.min.css', array(), '4.7.0' );

    If you haven’t edited the theme at a code level then it means something else is dequeuing the file or the file isn’t loading due to the standard handle, font-awesome. A plugin conflict test would be the quickest way to establish this.

    If you’d prefer to not locate the source of the problem and add the file back, you could use a function as follows:

    function ultra_child_fa() {
    	wp_enqueue_style( 'ultra-font-awesome', get_template_directory_uri() . '/font-awesome/css/font-awesome.min.css', array(), '4.7.0' );
    }
    add_action( 'init', 'ultra_child_fa' );

    That should work inserted as a function in Code Snippets. If you use Code Snippets, set the function to run on the front-end.

    I’m, unfortunately, offline now. Hope you’re able to make progress 🙂 Cheers.

    I haven’t edited any theme files. I’ll try disabling the plugins. I’ll also compare what plugins the two sites have in common, if any.

    Theme Author Andrew Misplon

    (@misplon)

    Sounds good.

    I tested the function above so that should work in Code Snippets if you want to go that route.

    I decided to go ahead and try the code snippet. Worked perfectly! Thank you so much!

    Theme Author Andrew Misplon

    (@misplon)

    Super, glad that helped 🙂

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.