Support » Theme: OceanWP » Mobile Menu not working

  • I’m using OceanWP with Elementor and there seems to be a clash with these two. The mobile menu won’topen when Elementor is active. All other plugins have been tested and it is definitely a clash between these two. When inspecting the code the menu code is greyed out when in mobile view.
    I have notified Elementor and they’re wondering if you know of this conflict and what the fix is if you do?
    Is this a Javascript thing cos I also found an error “ReferenceError: elementor is not defined”
    Thanks for any help that can be provided.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello,

    Can you try to remove the Carousel temporarily form the page and check it works or not after clearing the cache?

    Thread Starter rusty_compass

    (@rusty_compass)

    I removed both carousels on the page and cleared the cache but no change. I did however make a new page with nothing on it and the menu works there. So it must be something on that page??

    Okay, then duplicate the home page and try removing the elements on by one to check which element is causing this issue.

    Thread Starter rusty_compass

    (@rusty_compass)

    Fixed!
    I duplicated the home page ( who knew you could do such a thing! – thank you duplicate plugin.) and tracked down the culprit. It was some weird code sitting behind a text box that was causing the problem. After retyping the text everything worked great.
    Thank you for your help.

    Glad to hear that it is fixed!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Mobile Menu not working’ is closed to new replies.