Support » Theme: Twenty Seventeen » Mobile menu doesn’t work

  • Hi!

    I’m having a little problem that seems weird to me. But I don’t have in depth knowledge about coding so it might make a lot of sense to you guys. Anyway, I hope you can help me with this!

    So I installed a SSL certificate trough Directadmin, and since then some scripts seem to be not functioning anymore. My biggest concern is the mobile menu not working again. It seems active as you can click on it, but it doesn’t seem to run any script. I tried disabling all the plugins, but nothing changed. The thing that makes the mobile menu work again is: 1. Using the default twentyseventeen theme. 2. Visiting the site trough http instead of https. So it must be a conflict between something I changed and the SSL certificate. But I really don’t understand why this happens. I removed the line that forces the user to visit the site trough https so you can see it as well. It would be really great if someone could help me out with this!

    Thanks so much!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Could it be the change from http to https? I think this affected one of my sites one time.

    Are the scripts you are running full urls rather than relative?

    I cannot remember exactly where the setting is, but I hope someone else should be able to help you.

    So I figured out what caused this error. In the theme they try to load Jquery through a http link, which caused conflict in the https version of my website. This resulted in the not-functioning of scripts using Jquery. Solution here was to just use a https link in stead of a http link to the Jquery script.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.