WordPress.org

Forums

Magazine Basic
[resolved] Mobile menu bar with menu not appearing (4 posts)

  1. lutetia
    Member
    Posted 1 year ago #

    When I view the site on my iPad Mini (portrait view) there is no black menu bar showing up at the top (therefore no menu or home button). Visitors have no way of accessing the menus or left sidebar.

    (using my desktop computer and shrinking the browser window, however, the black strip does appear at the top, with a home button and a menu button.)

    Any ideas what could be causing this and how to fix it?

  2. lutetia
    Member
    Posted 1 year ago #

    I resolved this by updating my child theme CSS and header files (mobile navigation menu code) to include the latest changes in the theme files...

  3. Raspsu1
    Member
    Posted 1 year ago #

    Hi. Can you please give me some more information on how you fixed this problem? I'm having the same issue when I try to view http://maltinfusers.org on a mobile device.

    Thanks.

  4. lutetia
    Member
    Posted 1 year ago #

    What I did was compare my child theme CSS file mobile navigation code (near the bottom) with the mobile navigation code in the latest version of the parent theme CSS (I recently updated to the latest version of Magazine Basic).

    It was not the same. So I copied and pasted the mobile navigation code from the parent theme CSS file to the right place in my child theme CSS file.

    Don't know if this is the proper way to go about it, but it worked for me.

    Here is the code I now have for mobile navigation at the bottom of the CSS file:

    http://gw.gd/Rq46

    And in the header file I changed the following code in my child theme file:

    http://gw.gd/ocNd

    to this code, which I got in the parent theme header file.

    http://gw.gd/WS0m

    As you can see, parts were missing....

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic