Support » Fixing WordPress » Mobile-Friendly Test – Page partially loaded

  • https://search.google.com/test/mobile-friendly

    For some reason some pages are getting errors shown here.

    /photos/xatea-390x260.jpg	Image	Other error
    /wp-content/aoptimze/css/sd834756e4da7.css	Stylesheet	Other error
    /wp-content/plugins/js_composer/assets/css/js_composer.min.css	Stylesheet	Other error
    /wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js	Script	Other error
    /wp-content/plugins/js_composer/assets/lib/waypoints/waypoints.min.js	Script	Other error
    /wp-content/plugins/mega-addons-for-visual-composer/css/ihover.css	Stylesheet	Other error
    

    I’ve checked a fetch and render too and it seems some things are ‘Temporarily unreachable’ They explain it as “Note the URL is not unreachable for all of Google– it is just unreachable for the Fetch as Google simulation tool.”

    The “This is how a visitor to your website would have seen the page:” seems fine. It looks like it is a Googlebot issue.

    I use cloudflare, they said nothing wrong with my setup on their end.
    My robots.txt doesn’t reference those dirs

    # global
    User-agent: *
    Disallow: /cgi-bin/
    Disallow: /wp-content/cache/
    
    User-agent: ia_archiver
    Disallow: /

    To be sure I sent into robots.txt Tester and tested those URLs.
    They were fine of course.

    • This topic was modified 1 year, 2 months ago by funsail.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Could you provide a link to your page?

    It might be that some file references are being inserted dynamicly with java script after page load. googlebot cannot see these things sometimes. think of googlebot like curl, but with some understanding of java script.

    Here’s the page and result

    http://tiny.cc/usu4yy

    The render bot renders it fine.

    I’m guessing now…

    You are in Australia? Don’t know if there’s an issue, but does the googlebot use australian servers for testing? if not, there might be timeouts?

    Yes that’s true but I believe because I have cloudflare then googlebot will be able to be served from those servers. And it’s only this part and not the Fetch and render bot

    At the end of the day, it matters that the Website is working.
    I would not put too much effort in satisfying only the googles.

    I have the similar issue with (Google Mobile-Friendly) tool and (Fetch as Google) mobile version is broken because Googlebot is not loading my style.css and affect my rankings so I output my stlye.css code for mobile manually

    add_action('wp_head','load_mobile_styles');
    
    function load_mobile_styles () {
    
    if( wp_is_mobile() ) {
    
        ob_start(); ?>
        <style>
    enter code here
        </style>
        <style>
    enter code here
        </style>
        <?php
        echo ob_ob_get_clean();
    }
    }
    bhargavjoshi191

    (@bhargavjoshi191)

    @mohisnhassan618

    Hi,

    Thanks for your code share, can you please share the detailed code for calling of action hook and functioning.

    Thanks in advanced.

    Regards

    mohisnhassan618

    (@mohisnhassan618)

    add_action('wp_head','load_mobile_styles');
    
    function load_mobile_styles () {
    
    if( wp_is_mobile() ) {
    
        ob_start(); ?>
        <style>
          body {
             dispaly:block; 
          }
          // you can paste all your style.css code here 
        </style>
        <?php
        echo ob_ob_get_clean();
    }
    }
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Mobile-Friendly Test – Page partially loaded’ is closed to new replies.