Support » Plugin: Ad Inserter - Ad Manager & AdSense Ads » Mobile Ads show Twice

  • Resolved Mas Hadid

    (@mashadid)


    Hi, there,

    I’ve got problem after update ad inserter pro to the new version (2.6.16). It showed ads twice on single post (mobile version).

    Here is the condition:

    – I only put the code for posts. Nothing else. And the problem appears only on “posts type”.
    – there ad two ads shown on single post although I only put single code on each block (it is block 1 and 2)
    – For mobile phone I insert the code on “before content” (block 1), and “After Content” (block 2)
    – I only place and then activate the code for phone/mobile and tablet, so it won’t show on desktop.
    – I have activate remote debugging.

    Here is a screenshot to help you understand the problem.

    IMG

    I have been using filter to prevent that problem, but nothing seem to work for my web.

    Can you show me how to solve the problem. Thanks.

    • This topic was modified 12 months ago by Mas Hadid. Reason: add SS
    • This topic was modified 12 months ago by Mas Hadid. Reason: add more information
    • This topic was modified 12 months ago by Mas Hadid. Reason: add more information

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Spacetime

    (@spacetime)

    Hello, you should use this form for questions related to Ad Inserter Pro.

    However, this question applies also to free Ad Inserter so I’ll answer it here.

    I see both blocks inserted only once.

    You can use debugging function Label blocks to see which block is inserted:
    https://adinserter.pro/documentation/debugging

    Please check.

    Thread Starter Mas Hadid

    (@mashadid)

    Ahh I’m sorry. Should I move there, so that I get support which intend for user with pro version of the plugin?

    Thread Starter Mas Hadid

    (@mashadid)

    By the way, are you sure only see one on each block? because I still see the code on each block generated twice.

    Plugin Author Spacetime

    (@spacetime)

    Can you please post a screenshot with labeled blocks?

    Thread Starter Mas Hadid

    (@mashadid)

    You can see here.

    Image

    Plugin Author Spacetime

    (@spacetime)

    There is no debugging info.

    Label blocks and then make it again.

    Thread Starter Mas Hadid

    (@mashadid)

    It showed something like this.

    Error

    What do youy suggest?

    Plugin Author Spacetime

    (@spacetime)

    This is block 4 and it is not inserted because the impression limits were reached.

    Thread Starter Mas Hadid

    (@mashadid)

    It is getting weird for me.

    On normal condition, the block 1 and 2 show 2 ads each, but it turns out everything seemed to be fine when I examine them through Label Blocks

    However, when I test another block, it show me two ads insertion on single block (widget), as I shown here.

    Image error

    I don’t know what’s wrong with this, but I can tell you in my side: one code generate 2 blocks through single insertion.

    Plugin Author Spacetime

    (@spacetime)

    I see block 4 inserted only once?

    Please attach a screenshot with a block inserted two times.

    Thread Starter Mas Hadid

    (@mashadid)

    The screenshot I sent to you before was shown that a block inserted two times. Sorry not telling you that. That’s the condition I must face.

    That means from a screenshot I have sent you, there are two blocks although I only use one code.

    ====
    However,

    I’ve got the answer here.

    Everything back to normal when I change “Client-side detection to” from “Insert” to “Show”. It shows normal block. However, is it bad if I use “Show” for “Client-side Detection”? Because your documentation suggest to use “Insert” for adsense.

    Thank you

    Plugin Author Spacetime

    (@spacetime)

    I’m sorry but the screenshot you have attached shows block 4 inserted only once.

    I can’t help until I see the problem.

    Thread Starter Mas Hadid

    (@mashadid)

    Hi, there

    I’m sorry to cause misunderstanding here.

    It seemed that the cache plugin was causing malfunction on my browser so I had to deactivate the plugin first before your plugin works fine on my side.

    Therefore the problem is solved. Thank you very much for your fast response. It worth.

    • This reply was modified 12 months ago by Mas Hadid.
    Plugin Author Spacetime

    (@spacetime)

    You are welcome šŸ™‚

    Thank you very much for your fast response. It worth.

    Please say it here:
    https://wordpress.org/support/plugin/ad-inserter/reviews/#new-post

    Thank you!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Mobile Ads show Twice’ is closed to new replies.