Support » Plugin: Loco Translate » Mo files not loading.

  • Resolved rksh8148

    (@rksh8148)


    Hi
    I am using dokan-lite plugin. This plugin doesnt support multilingual by default. But it comes with pot file. I just used the Loco Translate to create po and mo files.
    My site is in 3 languages: zh_TW, zh_CN and en_US.
    And translation files are here:
    /wp-content/languages/plugins/dokan-lite-en_US.mo
    /wp-content/languages/plugins/dokan-lite-en_US.po

    /wp-content/languages/plugins/dokan-lite-zh_CN.mo
    /wp-content/languages/plugins/dokan-lite-zh_CN.po

    /wp-content/languages/plugins/dokan-lite-zh_TW.mo
    /wp-content/languages/plugins/dokan-lite-zh_TW.po

    Now I am facing this problem: the whole content of this plugin displaying string in chinese and english, even if you toggle between languages.
    I am in any language, its content remains unchanged.
    Please help me to fix it.

    I am using qTranslate-X plugin.

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Tim W

    (@timwhitlock)

    Do you know for a fact that “dokan-lite” is the text domain of your theme? Did you check the no.1 FAQ?

    I you need help with a specific theme, please post a download link.

    I am using this plugin:
    https://wordpress.org/plugins/dokan-lite/

    And I matched all the causes from https://localise.biz/wordpress/plugin/faqs/not-showing
    And all are fine.
    I tried to see which mo file loading using filter. And on change right mo file(according to file path) loads.
    But in display their translation everytime its same.

    Plugin Author Tim W

    (@timwhitlock)

    I can confirm that dokan-lite is the correct text domain, and as you say the MO files are loading correctly.

    You are storing your files under languages/plugins which means Loco Translate is not involved in loading the files or displaying the strings.

    As far as this goes, it seems that Loco Translate has done its job. It has saved MO files to the correct location with the correct names. Do you have any reason to believe this part has not worked? If you’re unsure then post a link to your MO file.

    Actually, the page comes after login. But the issue is also at login page:
    https://temp.sellticketnow.com/en/%E6%88%91%E7%9A%84%E5%B8%90%E6%88%B7/

    On this page, you can see radios with some label. When you toggle in any language it always remains in same language.
    I am attaching link for po and mo files.
    https://temp.sellticketnow.com/wp-content/languages/plugins/dokan-lite-zh_TW.mo
    https://temp.sellticketnow.com/wp-content/languages/plugins/dokan-lite-zh_TW.po

    And as I assuming, that each mo file have same content. Thats why its not showing different content on different language.

    Plugin Author Tim W

    (@timwhitlock)

    The first thing I note is that only one of your language files (zh_TW) has a translation of these radio buttons (“I am a customer” / “I am a Vendor”).

    There is no translation in your zh_CN file for these strings, and the en_US version is identical to the default string, so is absent from the MO file. (that’s how MO format works, to save space)

    So it looks to me like whatever you’re using to switch languages dynamically, (I assume that’s what qTranslate-X does) it is using the zh_TW version in all cases. Probably because zh_TW is the “Site Language” in your main WordPress settings so when there is no other translation, this is what gets used.

    As there is nothing wrong with your PO or MO files, this is not an issue related to my plugin and I have to mark this topic as resolved.

    If there is no other translation then it should show default plugin language which is English.
    And I didnt translated zh_CN yet. So please forget that for some time.
    But still, English and Tranditional Chinese should work as expected, Which is not working. I created po and mo for english also, because it was not working.
    I tried by removing english mo/po files. But not worked.
    Now, can you please you please suggest me anything to overcome this problem?
    I will be thankful.

    Plugin Author Tim W

    (@timwhitlock)

    1. English files will make no difference, as I explained.
    2. Your site language (not plugin language) is zh_TW.

    I strongly suspect these two facts are why your language switcher plugin is not falling back to the “plugin language” as you say. You assume it should work that way, but evidently it does not. It looks for an English string and doesn’t find one (point 1). Then it falls back to zh_TW because that is what you’ve said you want as your default (point 2).

    As your problem is not being caused by my plugin, I cannot offer you any further help with your language switcher and I suggest you contact the author to confirm that what I’ve said is correct.

    Plugin Author Tim W

    (@timwhitlock)

    Regarding the en_US files. If you want to force an English translation to be compiled into your MO files, then make it different to the original text. Even “I am a vendor.” (with a full stop) would work.

    Thanks to consider.
    I tried this way. But still loading same mo file.
    I added different content. But no luck.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Mo files not loading.’ is closed to new replies.