Support » Plugin: Media Library Assistant » MLA doesn’t let cdfv2 get uploaded

  • Resolved zxurian

    (@zxurian)


    I have a file type of .rfa (CAD file).
    linux identifies it as “Composite Document File V2 Document” (shown below), however there’s no where in MLA for me to add that in. I’ve tried adding the extension with application/octet-stream, but it still rejects it as a file not permitted.

    `
    [zxurian@ip-127-0-0-1 ~]$ file –mime-type test.rfa
    test.rfa: Composite Document File V2 Document, No summary info
    [zxurian@ip-127-0-0-1 ~]$ file -b –mime-type test.rfa
    Composite Document File V2 Document, No summary info
    [zxurian@ip-127-0-0-1 ~]$ file -i test.rfa
    test.rfa: Composite Document File V2 Document, No summary info; charset=binary
    [zxurian@ip-127-0-0-1 ~]$
    `

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author David Lingren

    (@dglingren)

    Thanks for your question and for including the details of your test.rfa file; very helpful.

    On my test system, I was able to add the rfa file extension and upload a test file of my own without any problems. Here’s what I did:

    1. Navigate to the Settings/Media Library Assistant “Uploads tab”
    2. Scroll to the “Add New Upload MIME Type” section on the left-hand side of the page.
    3. Enter “rfa” in the Extension text box.
    4. Enter “application/octet-stream” in the MIME Type text box.
    5. Select “binary” in the Icon Type dropdown list.
    6. Leave the “Inactive” check box unchecked.
    7. Enter “Composite Document File V2 Document” in the Description text box.
    8. Click the “Add Upload MIME Type” button to save the new type.

    Once that was done I was able to upload a .rfa file to my Media Library and see it show up in the Media/Assistant submenu table.

    If that doesn’t work for you, any additional details you can provide will help me investigate further. I will leave this topic unresolved for now and I hope the above outline is helpful. Thanks for your interest in the plugin.

    Plugin Author David Lingren

    (@dglingren)

    It has been six weeks since the last post in this topic. I hope the above suggestions were helpful.

    I am marking this topic resolved, but please update it if you have any further problems or questions regarding adding the rfa file extension to the uploads list.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.