Support » Plugin: Media Library Assistant » MLA breaking Add Featured Image

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author David Lingren


    Thanks for your report. It would be very helpful to know the name and source of the other plugin so I can investigate the combination and see if there is some interaction with MLA that’s contributing to your problem. If I can get a copy of the other plugin to test with I can be more helpful.

    Thanks for any additional information you can give me.

    Thanks for getting back to me.

    I’m afraid the plugin is commercial:

    However, disabling it has no effect. The WordPress ‘Add featured image’ remains broken.

    I don’t think I have any other plugins that pull up media library overlays but I am happy to investigate anything else that you might suggest.

    Plugin Author David Lingren


    Thanks for your quick response with this update. I will assume the other plugin isn’t involved for now. I have just re-run some tests using MLA 1.70 and both WP 3.8 and 3.5.2; Featured Image is working on my test system.

    Just to confirm – are you using MLA v1.70 and WordPress v3.8?

    When you say “the overlay comes up empty of content“, I understand that to mean you get the Media Manager Modal Window with all the menus and the toolbar, but nothing shows up in the Thumbnails area at the center of the screen; is that right?

    Do the “Create Gallery” and “Insert Media” menu selections have the same problem, or is it specific to “Set Featured Image”?

    Are the “Show All Dates” and “All Att. Categories” (if present) dropdown boxes populated? What happens if you pick a year/month value that you know has some images? What about other Media Types values?

    What happens if you go to the Settings/Media Library Assistant General tab, scroll down, uncheck the “Enable Media Manager Enhancements” checkbox, then scroll down and click the “Save Changes” button? Does disabling the MLA enhancements restore the Featured Image functionality?

    Thanks for taking the time to run these additional tests. Unless I can reproduce the issue on my test system there’s not much else I can do yet.

    3.8 and 1.70 – yes.

    Overlay empty of content – screen grab here:

    Add media: Same problem

    Show all dates etc: Not seeing this in the modal window or am I looking in the wrong place?

    Uncheck media manager: Everything works fine again.

    Plugin Author David Lingren


    Thanks for taking the time to run more tests, and particularly for the link to your screen shot, which is even more dramatic than I thought. You don’t see the “Show All Dates” dropdown because there is no toolbar or any other UI showing in the Modal Window.

    I noticed you are using Safari on a Mac; I use Internet Explorer on a Windows system. I tried Safari on Windows – it works for me.

    Have you tried another browser, e.g., Chrome? Do you have access to another system running Windows that you could try? You could also try setting/clearing the individual MLA Enhancements and see if the problem is related to a specific feature.

    The other way forward would be for me to access your site and do all this testing myself. If you’re willing to set up an Author or Administrator account for me, send the credentials by using the “Contact Us” page on our web site:

    Fair Trade Judaica/Contact Us

    I know that may not be possible and I completely understand. Thanks for your patience, persistence and understanding.

    Plugin Author David Lingren


    Thank you for contacting me and especially for giving me access to your site. At this point you and I have narrowed the problem down to a conflict between MLA and Simplified Google Maps. The problem only occurs when the WordPress “CONCATENATE_SCRIPTS” option is set to “true”. You can add a line to your wp-config.php file to avoid the conflict: define('CONCATENATE_SCRIPTS', false); This line must be above the " require_once(ABSPATH . 'wp-settings.php'); line in the wp-config.php file.

    I have exhausted my limited JavaScript debugging skills and cannot find the root cause of the conflict. I have sent all my findings to the Simplified Google Maps author and they are looking into it.

    I will leave this topic unresolved until I hear back from them.

    Plugin Author David Lingren


    I am delighted to report that I received a rapid and effective response from the Simplified Google Maps author. It included one updated file for their plugin that has solved the conflict on my test system. Let me know if the fix works on your system as well.

    I am going to mark this issue resolved, but if you have a problem please update it. Thanks again for all your help, your patience and your interest in the plugin.

    This has now been fixed via a patch from the developer of Simplified Google Maps.

    David has been an absolute star and has spent many hours investigating the problem.

    Many many thanks.

    Greetings! I have the same issue. I’m using the latest version of WP with Cherry Framework. I have a similar issue and I’m not using the same plug-in. Any suggestions on how to tackle this one.

    Plugin Author David Lingren


    Thanks for your report. I had a quick look at the Cherry Framework site; it looks like a great platform and theme source. If I can find a free version to work on I can do some experiments. I hope this tutorial will be sufficient:

    How to create a child theme based on Cherry Framework

    Can you tell me more about the Cherry Framework and specific theme you are using? What versions are you using?

    In the interim, it would be very helpful if you can do a few things to narrow the problem down:

    1. If you are using other plugins, try deactivating them to see if you have the issue with just the Cherry Framework + MLA, or if another plugin might be involved.
    2. Try adding define('SCRIPT_DEBUG', true); to your wp-config.php file. This loads the development (non-minified) versions of all scripts and CSS, and disables compression and concatenation.
    3. Replace step 2 with define('CONCATENATE_SCRIPTS', false);, which disables compression and concatenation of scripts and CSS.

    Let me know if those experiments give you any further specific information on the problem’s cause. Thank you for your patience and your help while I investigate this issue.

    Cherry Framework 3.14 using ‘Regina’ as the theme. Gonna try to add later on tonight. Hope it works. Thanks in advance!

    Plugin Author David Lingren


    I have created a new test site with WordPress 3.9.1 and Cherry Framework 3.1.4.

    On my test site the “Set Featured Image” and “Add Media” functions bring up the Media Manager Modal Window without errors. It works with define('SCRIPT_DEBUG', true); and define('SCRIPT_DEBUG', false);.

    I was also able to use the MotoPress Editor to add Image and Slider elements to a post. The “Select Image” and “Select Images” popup windows show the MLA enhancements and are working for me.

    The MotoPress editor is throwing some JavaScript errors in the load-scripts.php file, but they don’t seem to be MLA related.

    Have you had a chance to try the above experiments? You can also try going to the Settings/Media Library Assistant General tab, scrolling down to the Media Manager Enhancements section, unchecking the “Enable Media Manager Enhancements” box and saving your changes. That should stop sending the MLA JavaScript files to the browser and avoid your issue without removing all the other MLA functions.

    Let me know how you’re doing. I will keep investigating as well.

    Hi David! I haven’t got a chance to try – looking to make some free time today for it.

    @david: I got a chance to disable the advanced checkbox and that worked! I didn’t have to edit the code – thankfully. I do however need more practice. Thanks again for the suggestion!

    Plugin Author David Lingren


    Thank you for posting this update; when you say “disable the advanced checkbox“, do you mean you unchecked the “Enable Media Manager Enhancements” box?

    That will avoid the problem, but you won’t have access to the MLA enhancements for the Media Manager. I would still be interested in knowing what happens on your site if you modify the wp-config.php settings as outlined above. That might help me actually find the problem and fix it for everyone.

    Either way, thanks for your help and your interest in the plugin.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘MLA breaking Add Featured Image’ is closed to new replies.