• Resolved majal

    (@majal)


    Hi. Let me first say that this plug-in is awesome. 🙂

    I just noticed today that Chrome console is giving a warning. This was not here last week. Here is the warning message:

    Mixed Content: The page at ‘https://www.majlovesreg.one/oneness-begins‘ was loaded over HTTPS, but requested an insecure image ‘http://www.majlovesreg.one/wp-content/plugins/photonic/include/images/loading.gif‘. This content should also be served over HTTPS.

    I have rewrites and automatic redirects from http to https, but even that did not get this link right. It is present in every page where a Photonic gallery is active, but does not happen in my other pages. I wonder where the problem is from… Thanks for the amazing support!

    • This topic was modified 3 months, 2 weeks ago by  majal.
    • This topic was modified 3 months, 2 weeks ago by  majal.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Sayontan

    (@sayontan)

    I tried loading the page you have linked – I don’t see a mixed content warning in Chrome.

    One thing I noticed on your page is that you are using a lazy-loading plugin. That is likely to cause conflicts with Photonic. E.g. the aspect ratio of your photos seems to be incorrect. Photonic’s layout engine requires the full image to be loaded so that it can determine the size of the image. A lazy-loading plugin interferes with this behaviour and hence causes conflicts.

    Hi @sayontan!

    Thank you for your quick reply. You’re right. I just reloaded the page just now and it no longer has the Mixed Content warning. I really don’t know what happened. It seemed to just have corrected itself.

    On lazy loading, you pinned it as well. So I went ahead and disabled PageSpeed’s lazyloading of images. In a related note (I’m not suggesting a feature request because I’m sure you’re busy) PageSpeed skips lazyloading images if it contains the data-pagespeed-no-defer attribute inside the <img> tag. 🙂

    Thank you for your reliable support always!

    All the best,
    Majal

    • This reply was modified 3 months, 1 week ago by  majal.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.