Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter diogomarques

    (@diogomarques)

    Ps: usually I’d go into the exclusion section of asset optimization and just disable the font and/icons from being optimized. However I can’t find anything named revicons. Thank you!

    Plugin Support Nithin – WPMU DEV Support

    (@wpmudevsupport11)

    Hi @diogomarques,

    I could notice the issue on your website. This looks more like the home URL, or the site URL has http instead of https.

    Could we know whats the URL configured under Settings > General for the “WordPress Address (URL)” and “Site Address (URL)”?

    Could you please confirm the URLs start with https instead of http?

    Please do let us know how that goes so that we could check further. Looking forward to your response.

    Kind Regards,
    Nithin

    Thread Starter diogomarques

    (@diogomarques)

    Hi Nithin,

    You can see this issue going to this page: https://arquid.pt/ and inspecting it with chrome dev tools, at least that’s how I’m doing it.

    And yes, all my urls start with Https:// so I’m not sure why this is happening.

    Thank you!

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @diogomarques

    Could you please try this script? https://gist.github.com/patrickfreitasdev/e8092a06a700e194ed872b0b6d979076

    You can install it as a mu-plugin following this guide https://wpmudev.com/docs/using-wordpress/installing-wordpress-plugins/#installing-mu-plugins

    Replace the line where it says:

    $content = str_replace('http://yourwebsite.com', 'https://yourwebsite.com', $content );

    To your domain.

    Make sure to keep first as HTTP:// and the second one as HTTPS://

    Once done, clear all aches and check if the issue is gone.

    We got some cases where the hosting was forcing the HTTP and this should prevent the issue.

    Let us know the result you got.
    Best Regards
    Patrick Freitas

    Thread Starter diogomarques

    (@diogomarques)

    Hi!

    Problem still persists. It’s actually pretty weird, I’ll try to explain:

    Without hummingbird no error is never shown. After I activate hummingbird and caching takes place I can see the <!– This page is cached by the Hummingbird Performance plugin v3.3.2 – https://wordpress.org/plugins/hummingbird-performance/. –>” it still shows no errors.

    After I’d say 3 or 4 hours or hummingbird being active the error starts showing up. What can I do? This seems so weird but I’ve tried a couple of dozen of times and it always behaves like this… 🙁

    Thank you for the help!

    Plugin Support Kris – WPMU DEV Support

    (@wpmudevsupport13)

    Hi @diogomarques

    I hope you are doing good today.

    With Asset Optimization disabled on your site (add this code into site URL “/?avoid-minify=true”) it seems your font load via relative path “../”.
    With Asset Optimization enabled your font load via absolute path and for some reason, it takes HTTP, instead of HTTPS.

    If in the meantime “WordPress Address (URL)” and “Site Address (URL)”? was changed from HTTP to HTTPS this could be the issue. Please re-run again Asset Optimization a clear all cache on the site and cache server-side and let us know about the results.

    Kind Regards,
    Kris

    Thread Starter diogomarques

    (@diogomarques)

    Hi Kris,

    Using the link https://arquid.pt/?avoid-minify=true seems to remove the error, although this is not a fix ahah.

    The website url has always been https:// so I don’t believe that is the issue. I have rerun asset optimization and cleared cache dozens of time, never fixes the issue…

    Any idea? I have had this page (with hummingbird) for almost a year and it never showed this problem

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @diogomarques !

    Hope you’re doing well today!

    Two more possible solutions for this:

    1. Using Better Search Replace plugin to ensure that everything in the database uses the https:// prefix

    https://wordpress.org/plugins/better-search-replace/

    Very important: before using it, please make sure you have a backup of the site.

    Also: when running the replacements, please make sure to replace from http:// to https://, not from just http to https.

    2. Excluding the rs-plugin-settings CSS file from Asset Optimisation – this should fix the relative path issue:

    https://monosnap.com/file/nUPkXnuaKqsDTmzeJBPSEDYFszTFvG

    Both can be used at the same time, but it’s possible either one will work as well. The second one is quickest but it also excludes a file from being optimised.

    Best regards,
    Pawel

    Thread Starter diogomarques

    (@diogomarques)

    Hi Pawel!

    Well the issue is back, but now I see what is causing it! I created a staging website without hummingbird to check the files.

    I have two problems:

    1) I have excluded the two CSS files that is causing this issue on Hummingbird from optimization:
    revmin (file: https://staging.arquid.pt/wp-content/plugins/revslider/public/assets/js/rs6.min.js)
    rs-plugin-settings (file: https://staging.arquid.pt/wp-content/plugins/revslider/public/assets/css/rs6.css)

    However hummingbird is still optimizing them.

    2)
    The problem is actually that in the original css file the code is as such:

    @font-face {
      font-family: 'revicons';
      src: url('../fonts/revicons/revicons.eot?5510888');
      src: url('../fonts/revicons/revicons.eot?5510888#iefix') format('embedded-opentype'),
    	   url('../fonts/revicons/revicons.woff?5510888') format('woff'),
    	   url('../fonts/revicons/revicons.ttf?5510888') format('truetype'),
    	   url('../fonts/revicons/revicons.svg?5510888#revicons') format('svg');
      font-weight: normal;
      font-style: normal;
      font-display: swap;
    }

    Whenever hummingbird optimizes it, it ads a http:// instead of https://. I found a user with the exact same problem as mine: https://wordpress.org/support/topic/hummingbird-converting-relative-url-to-non-https/? but you guys fixed their issue privately through e-mail I guess. So i can’t find the fix.

    Any help? Thank you!

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @diogomarques

    Sorry for the delay here.

    It seems we didn’t receive a notification about your response.

    The fix for that situation was the same shared script from https://gist.github.com/patrickfreitasdev/e8092a06a700e194ed872b0b6d979076

    I can see you are using cPanel, can you double check if you have the force HTTPS checked in cPanel? https://blog.cpanel.com/force-https-redirection/

    On the pointed ticket, we found the site/server was forcing the HTTP even it was loading under HTTPS, we used this script to find this out https://gist.github.com/patrickfreitasdev/b3e875a43df35086b25ec29a67ee83ae

    You can disable the Hummingbird, apply the above script and check the test.txt which will be generated in your wp-content > mu-plugins.

    Best Regards
    Patrick Freitas

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @diogomarques ,

    We haven’t heard from you for over a week now, so it looks like you don’t have any more questions for us.
    Feel free to re-open this ticket if needed.

    Kind regards
    Kasia

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Mixed content revolution slider’ is closed to new replies.