Support » Plugin: Jetpack by WordPress.com » Mixed content problem

  • Resolved MartinCap

    (@martincap)


    Since upgrading to Jetpack 5.0 on WordPress 4.7.5 we have a mixed content warning for the following file in our HTTPS WordPress backend:

    wp-json/jetpack/v4/jitm?message_path=wp%3Adashboard%3Aadmin_notices&query=&_wpnonce=4b197d8eaf

    That file is being served over HTTP rather than HTTPS.

    Is there a way to fix this?

    We force HTTPS on the backend but HTTP on the frontend.

    • This topic was modified 1 year, 9 months ago by  MartinCap.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Thanks for reaching out. The file seems to be part of some messages/notices that Jetpack displays, Do you have any notices by Jetpack on your admin page at the moment? If so, can you please take a screenshot of the notice and send it across?

    Hi, I was using WordPress 4.7.5 at the time of the mixed content problem.

    There were no notices in the admin page from Jetpack at that time.

    However, we’ve just upgraded to WordPress 4.8 and the Jetpack Admin notice about enabling Vaultpress backups came up after the update.

    We closed it and now the mixed content problem is gone.

    Thanks for your reply.

    To add to this however, although the mixed content issue is fixed, we are seeing the following request in our logs every single time we load a page in the admin page:

    wp-json/jetpack/v4/jitm?message_path=wp%3Aedit-post%3Aadmin_notices&query=&_wpnonce=cdf8d1cc12

    There are no notices showing in the admin area from Jetpack or any other plugins.

    Same issue. Any fix?

    Hi,

    We’re still seeing this in our logs every time we load a page in WP-Admin

    /wp-json/jetpack/v4/jitm?message_path=wp%3Aedit-post%3Aadmin_notices&query=&_wpnonce=1dc587fb6e

    To be clear, there is no notice showing at all.

    Martin

    Hi Martin,

    That’s from Just In Time Messaging (JITM) checking the path of the page and then seeing if a message needs to be displayed or not – in most cases and yours it’s just returning an empty string. You could completely turn off any messages using the filter stated here:

    https://github.com/Automattic/jetpack/blob/master/class.jetpack-jitm.php#L338

    Hi Lamday,

    Thanks very much for your reply.

    I’ve tried disabling JITM by adding the following code to our functions.php file:

    add_filter( 'jetpack_just_in_time_msgs', '__return_false', 99 );

    However, the issue persists. On every single page load in WP Admin, we something like the following on our server:

    /wp-json/jetpack/v4/jitm?message_path=wp%3Aedit-post%3Aadmin_notices&query=paged%253D6&_wpnonce=97ab0770dc

    Each query of this type takes about a second to execute.

    To be clear, this problem only started when we installed Jetpack 5.0, so I think it may be a problem with the plugin?

    Many thanks,
    Martin

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Mixed content problem’ is closed to new replies.