Support » Theme: Hexa » mixed content problem

  • Hi,
    the website filmleaks.org is not save because there exist a mixed content.
    This is shown in the “console”.

    Mixed Content: The page at ‘https://filmleaks.org/’ was loaded over HTTPS, but requested an insecure image ‘http://filmleaks.org/wp-content/uploads/2015/04/Slogan_2000_200W.png’. This content should also be served over HTTPS.

    Has anybody any idea, how to get out this script?

    I know nothing from php until now (because this it is not my profession), and would be thankfull if somebody could explain i a view words which file i have to change, and where (via ftp) i could find him….

    If it is so simple….

    Thank you very much for support,
    Florian

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hello @ofzoe

    The problem you’re having is because you most likely had a regular http website and then you upgraded to https (cloudflare?)

    When you do that, all the of attachments are still linked with http links, in order to fix that there a fewthings you can do,

    1- Turn on Automatic HTTPS Rewrites Under the Crypto tab in Cloudflare settings ; or

    2- Manualy edit the links and change http to https ; or

    3- Install a plugin to fix mixed content.

    Hope this works.

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    As j09 mentioned, this isn’t a theme issue. Let us know if one of the above methods fixes the issue.

    You could try a plugin like this one, which will force-load static files on an https connection:

    https://wordpress.org/plugins/https-redirection/

    If you started using SSL from day 1 of your site then all your static files are already embedded using HTTPS URL. You have no issue there.

    However, if you have an existing website where you have a lot of static files that are embedded in your posts and pages using NON-HTTPS URL then you will need to change those. Otherwise, the browser will show an SSL warning to your visitors.

    This plugin has an option that will allow you to force load those static files using HTTPS URL dynamically.

    Hi, and thank you very much for your open ears.

    It is true, I changed from http to https, but I have no cloudflare or something like that.
    The side is on a normal server, website managed by my own.
    The point is, with the change all images have transformed to https alone, but there is “somewhere” one pic, which ist not anymore in the website or on the media-files at all.

    But the code is fixed and goes not away.

    I would like to prefer what j09 mentioned:
    “Manualy edit the links and change http to https ;” or better delete the wrong link.

    But, in which php-file this small gremlin-code is hidden???? And how could it localized.

    I know to work with ftp and texteditor to change php-files….

    Florian

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    Two ways: you could use a database-search tool to find the reference to the image http://filmleaks.org/wp-content/uploads/2015/04/Slogan_2000_200W.png or you could open every post to find it. The database route might be faster depending how many posts you have.

    To search the database you could use phpMyAdmin – usually accessible through your hosting control panel. Be careful if you go this route as you can cause inadvertent damage by changing database values directly. Or you could use a plugin like https://wordpress.org/plugins/better-search-replace/.

    • This reply was modified 2 years, 6 months ago by  Kathryn. Reason: fixed typo

    Hi Kathryn,
    I used the plugin. It works! Very easy! Great – thank you and come in for a cup of tee, if you in frankfurt am main ,)…
    I recognized also now what happend. The image was totaly white (used for the background), and this was the reason because I thougt, that there is no background image anymore…

    Kind regards,
    Florian

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘mixed content problem’ is closed to new replies.