Support » Plugin: CDN Enabler - WordPress CDN Plugin » Mixed content issue despite HTTPS option enabled

  • Resolved CrimsonGuard

    (@crimsonguard)


    Hello
    Since a few days, I have an issue when CDN Enabler is activated.
    I use KeyCDN and I have mixed content issues because KeyCDN assets are loaded in HTTP instead of HTTPS.
    In CDN Enabler plugin, “CDN HTTPS” option is enabled.
    Database shows s:5:"https";i:1; which seems to mean it is enabled.
    I don’t understand what could have gone wrong because it has worked for months before that.

    This is no cache problem, the problem persists when I disable or flush SiteGround cache.
    Furthermore, I already tried uninstalling and re-installing CDN Enabler.
    Any idea?
    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Which SSL option do you currently have enabled in your KeyCDN zone? Also are you using https:// for your CDN URL in CDN Enabler?

    SSL option on KeyCDN is on “shared”.
    We use Let’s Encrypt.

    I don’t understand your 2nd question.
    In my 1st message, I said

    In CDN Enabler plugin, “CDN HTTPS” option is enabled.

    Is this what you want to know?

    I am referring to your actual CDN URL used within CDN Enabler. In your case, this should begin with https://zone-1c6b.kxcdn.com for example.

    Can you provide the CDN URL you used in that field of the plugin?

    That was the trick.
    Shame on me for not seeing it, the URL field had HTTP instead of HTTPS.
    I don’t know how the “s” did go away but this is certainly not a plugin glitch.
    Thank you for your help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Mixed content issue despite HTTPS option enabled’ is closed to new replies.