Support » Plugin: Simple Event Planner » Mixed content issue

  • Resolved sancukosan

    (@sancukosan)


    Hi,

    Firstly, I must say that this is one of the best simple event plugins that I have seen so far. With a little more touch-ups, this can be one of the best plugins out there.

    Anyway, I’m here for a specific issue that appears after installing and activating the plugin.

    We are using WP Bakery page builder and for us, it works fine, we haven’t got any issue so far with this builder, but when we activate your plugin, we are not able to edit any of the elements on these Event posts. Even in every single menu of your plugin (All Events, Add New, Categories, and Settings), we are seeing the following console log message:

    In “All Events” menu:

    Mixed Content: The page at '/wp-admin/edit.php?post_type=event_listing' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint. This request has been blocked; the content must be served over HTTPS.

    In the “Categories” menu:

    Mixed Content: The page at '/wp-admin/edit-tags.php?taxonomy=event_listing_category&post_type=event_listing' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint. This request has been blocked; the content must be served over HTTPS.

    We are running our website over HTTPS and we didn’t have a problem until the activation of the plugin. Everything comes in normal if we deactivate the plugin.

    The plugin is so simple and important for us, so can you look into this? Maybe there are some HTTP requests in your JS files that can be switched?

    Kind Regards,
    Martin

    • This topic was modified 2 months ago by sancukosan.
    • This topic was modified 2 months ago by sancukosan.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author PressTigers

    (@presstigers)

    Hello @sancukosan,

    We apologize for the inconvenience.

    Can you please view the page source of the event listing page (Ctrl+U ) and find (Ctrl+F) the links that are on “http:”. Please let us know if there is any specific link hooked on http: we will surely provide the fix. As we are not able to reproduce this issue at our end.

    Feel free to reach us out if you have any further question.

    Regards,

    Thread Starter sancukosan

    (@sancukosan)

    Hi,

    Thanks for coming back.

    Yeah, I have done that previously but I didn’t found anything suspicious so that’s why I didn’t post it, but here is the result from all menus:

    View All Events, Settings, Categories (which is just a comment and doesn’t affect our websites):

    <!-- MapPress Easy Google Maps Version:2.57.3 (http://www.mappresspro.com/mappress) -->

    Add New Event/Edit Event:

    The same comment again:

    <!-- MapPress Easy Google Maps Version:2.57.3 (http://www.mappresspro.com/mappress) -->

    Also, these are something that didn’t affected our website previously, but it’s not from your plugin too:

    <p class="vc_ui-help-block vc_welcome-visible-e">
    			Don't know where to start? Visit our <a href="http://themenectar.com/docs/salient" target="_blank">knowledge base</a>.		</p>

    <div class="content"><textarea data-attrname="social"></textarea> <p class="description">Enter any social media links with a comma separated list. e.g. Facebook,http://facebook.com, Twitter,http://twitter.com</p></div><div class="clear"></div>

    <div class="content"><input class="attr" type="text" data-attrname="page_link_url" value="" /><p class="description">Enter portfolio page URL you would like to link to. Remember to include &quot;http://&quot;!</p></div><div class="clear"></div><div class="label">

    I really appreciate your work and I hope we will find a solution for it. Thank you again.

    Kind Regards,
    Martin

    • This reply was modified 2 months ago by sancukosan.
    • This reply was modified 2 months ago by sancukosan.
    Plugin Author PressTigers

    (@presstigers)

    Hello Martin,

    Thank you for providing a detailed log.

    Can you please activate the SEP, deactivate the Visual Composer plugin, and then see this conflict? Let us know if the problem still persists.

    Regards,

    Thread Starter sancukosan

    (@sancukosan)

    Hi,

    Thanks for coming back.

    Unfortunately, we cannot disable the WP Bakery plugin because our website is built on that, and our team would love to use that builder for creating the event posts. Also, this error seems to appear when you are trying to edit the WP Bakery element on the event post.

    For Example, I have created a new event and added a text block element, and saved the event post. After trying to editing it, the element never opens, and rotates continuously ( as it is presented on the following image.), causing an error. We do not have this problem with ordinary pages and posts.

    Kind Regards,
    Martin

    Plugin Support Zubair Ahmad

    (@jerrykza)

    Hi,

    Disabling the Visual composer plugin is just to find the conflict. It seems with the information you provided, it could be the Visual Composer plugin conflicting with the SEP which is why it’s not working as it should.

    Also, we haven’t yet made the SEP compatible with the Visual Composer plugin or tested it.

    We would recommend that you take help from an expert WP programmer to assist you with resolving the conflict.

    Regards,

    Thread Starter sancukosan

    (@sancukosan)

    Hi Zubair,

    Thanks for your answer, but disabling the WP Bakery plugin it’s a temporary fix to the issue because we need to use it anyway as a page builder.

    I hope soon there will be compatibility with the WP Bakery plugin.

    Kind Regards,
    Martin

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.