Support » Fixing WordPress » Mixed content error on wp-admin dashboard

  • Since upgrading to WordPress 4.9 I’ve noticed I’m getting the following mixed content warning only on the dashboard of the website:

    Mixed Content: The page at 'https://domain.co.uk/wp-admin/index.php' was loaded over HTTPS, but requested an insecure script 'http://domain.co.uk/'. This request has been blocked; the content must be served over HTTPS.

    It’s strange because it’s not actually pointing to a script. It’s saying that it’s tried loading the domain without https. I’ve performed an entire search through the website for any occurrences of my domain without https and I’d have zero results. I also have FORCE_SSL_ADMIN and FORCE_SSL_LOGIN enabled in my wp-config file, as well as redirecting all http requests to https via my .htaccess file.

    Does anybody have any ideas what could be causing this? I’m completely baffled! Here’s a screenshot of the problem: https://imgur.com/a/bFmWW

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    If you just view the page source, do you see http://domain anywhere in it at all, without the https?

    It’s nowhere to be seen in the source either. In fact, the only occurrences of http at all are the WordPress xmlns attributes.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Do you have both of the URLs on the the general settings screen as https instead of http?

    Correct, both the site address and WordPress address are pointing to the https version of the website – I’ve double checked this.

    UPDATE: I replicated my entire website over to testing subdomain and the issue still remained. I disabled each plugin for my website one-by-one and eventually found the culprit – Wordfence. This is why I couldn’t replicate the issue locally (because I didn’t have Wordfence configured on my local machine).

    I’m attempted to delete and reinstall but the problem still arises, so I’ve submitted a ticket to them:

    https://wordpress.org/support/topic/dashboard-mixed-content-error/

    Thanks for helping me look into this Otto. Next time I’ll remember to test each plugin first before submitting on here!

    Kind Regards,

    Liam

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Mixed content error on wp-admin dashboard’ is closed to new replies.