• Resolved zoecorkhill

    (@zoecorkhill)


    Hello

    I have installed this plugin for a client recently and after using the Asset Optimization module we ran into mixed content errors.

    The css being compressed was as follows
    @font-face{font-family:Social Pug;src:url(./socialpug.1.0.0.eot?gd6mr8);

    But in the compressed file it was:
    @font-face{font-family:Social Pug;src:url(http://www.REDACTED.co.uk/wp-content/plugins/social-pug/assets/dist/socialpug.1.0.0.eot?gd6mr8);

    Both the Site URL and WordPress URL in settings have https, not http.

    For now I’ve had to disable optimisation of that file, but I wanted to let you know and see if we could get it resolved.

    Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @zoecorkhill,

    I did some tests on my end with Social Pug plugin (Grow by Mediavine) and even with optimization enabled the URLs were using HTTPS and I didn’t get any mixed content errors.
    Here’s how the optimized file looks on my end
    https://monosnap.com/file/E1yssD3iJw2jABsIRILq3nlUCyxGDh

    Can you check if your site URL in Settings > General panel is using HTTPS, if not change it to HTTPS and see if Asset Optimization properly adds HTTPS link after that?

    Cheers,
    Predrag

    Hi

    As I already stated in my initial post, the urls are already both set to https.

    We’ve had to disable completely now as it was also doing it with another file.

    Thanks
    Zoe

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi Zoe,

    Sorry I missed that part, however, it seems that this is something specific to your installation as no matter what I tried with Social Pug and Hummingbird it was always processing the URL with HTTPS.

    Can you try using a plugin like Really Simple SSL and see if that solves the issue for you?

    Cheers,
    Predrag

    Hi

    I’ve been turning on and off individual files asset optimisation and some across a number of plugins are failing to use https – it is by no means limited to Social Pug. It also affects the theme css, and some other plugins including one of the metaslider css files.

    Oddly, a few files do work properly.

    Some examples of incorrect ones are:

    src:url(./socialpug.1.0.0.eot?#iefix)
    background-image: url(‘img/select-arrows.png’);
    background-image: url(‘../sliders/flexslider/bg_direction_nav.png’);
    background-image: url(‘img/slide-arrow-right.png’) !important;
    background-image: url(“img/slide-arrow-right.png”);

    Yet one of the wordfence files and one of the slider css files are using https as expected:

    #wfboxPrevious{position:absolute; bottom:5px; left:5px; background:url(../images/lightbox-controls.png) no-repeat -75px 0; width:25px; height:25px; text-indent:-9999px;}

    @font-face{font-family:flexslider-icon;src:url(fonts/flexslider-icon.eot);src:url(fonts/flexslider-icon.eot?#iefix) format(’embedded-opentype’),url(fonts/flexslider-icon.woff) format(‘woff’),url(fonts/flexslider-icon.ttf) format(‘truetype’),url(fonts/flexslider-icon.svg#flexslider-icon) format(‘svg’);

    The urls do switch to https with Really Simple SSL installed, but my client is hesitant to have yet another plugin running when the aim is to optimise her site rather than add more code. For now, we are choosing to have the misbehaving files turned off in asset optimisation instead.

    Thanks

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @zoecorkhill

    Thank you for the update.

    I did some deep tests on my website.

    I created a child theme and a custom CSS file to my website, I used a provided rule from your reply:

    background-image: url(“img/slide-arrow-right.png”);

    Just updated to my image and class.

    .customBackgroundImage {
      background-image: url("media/wpmudev.jpg");
      height: 300px;
      width: 100%;
    }

    You can see before enabling the assets module:
    https://monosnap.com/file/FGTTpcERfAdfS8A8E389spwaSmW8Tq

    So I combined and optimized some files:
    https://monosnap.com/file/Km16SsRftMtnoUmUy0xDx62TDVIcTJ

    When the files got optimized, the plugin added the HTTPS correctly:

    https://monosnap.com/file/exqmG8hXrGbIMAhofUE5P444ErL91a

    I also tested using the inline option which worked fine.

    It seems something on your end is not getting the correct URL on the WordPress settings and adding to the newly created file.

    Could you please run a dry search on your database looking for https://yourwebsite.com/ and update to https://yoursite.com/

    https://wordpress.org/plugins/better-search-replace/

    Selecting the Run as Dry won’t update the URLs, it only returns if any table needs to be updated.

    If so, you can run the process, just make sure to have a full backup before any update.

    Flush all caches and check if the issue is gone.

    Let us know the result you got,
    Best Regards
    Patrick Freitas

    zoecorkhill

    (@zoecorkhill)

    Hi

    I’m afraid I already thought of that and updated all the stray http URLs in the database to https, and emptied caches afterwards to check. It didn’t make a difference to the plugin behaviour.

    Thanks
    Zoe

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @zoecorkhill

    Thanks for response!

    updated all the stray http URLs in the database to https, and emptied caches afterwards to check.

    Did you also re-checked files in Humingbird’s Asset Optimization settings? If not, please give it a try to let Hummignbird actually “regenerate” these assets.

    Also, are there any plugins on site whatsoever that are in any way interacting with CSS like, for example, additionally caching it or having some sort of “minification”/optimization options built-in?

    I’m asking because one of the common cases is that there’s (either in a theme or in some other plugin) an additional “optimization” option built-in/enabled that’s causing conflicts, so it’s important to rule that out.

    Kind regards,
    Adam

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hello and thank you for using Hummingbird. We are going to close this ticket for now because we have not heard from you in a while. If you still need support we can reopen the thread.

    Cheers,
    Predrag

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.