Support » Fixing WordPress » Mistake deleting cache folder

  • Hi
    In one of the WP installations I updated today (2.3.2 -> 2.3.3), I found a wp-content/cache folder which I deleted – according to the upgrading instructions

    …wp-content folder; Special Exception: the wp-content/cache and the wp-content/plugins/widgets folders should be deleted.

    This folder was non-existing in the first update i did.
    Now, after running the upgrade script on this second installation, I got a 500 internal server error message, saying

    Warning: fopen(/web/htdocs/ [function.fopen]: failed to open stream: No such file or directory in /web/htdocs/ on line 96

    In other words, WP missed the cache folder that I deliberately deleted.

    My question is if this is a mistake in the upgrade instruction or if I just made some mistake myself.
    (Everything works as it should after I uploaded the missing folder from a backup.)
    Kjetil Flekkoy
    PS site: (work in progress…)

Viewing 7 replies - 1 through 7 (of 7 total)
  • Correction: The login and logout pages (at least) don’t work. Instead I get a 500 internal server error. Any ideas?
    Since this is critical, I’ve moved this as a question to the Troubleshooting pages.
    (Sorry if it seems like a double posting)

    Well, my guess is you did not deactivate all your plugins before running the upgrade…

    EDIT. And you don’t move postrs. We do if needed. YES, it is double posting if you do it.

    Thanks – that was quick
    But I did deactivate the plugins first.

    SORRY – this really appears as a double posting after my initial one in the feedback forum was moved here:

    First you should fix the basic setup: your permalinks and internal links don’t work. It seems you tried to use the Giving WordPress Its Own Directory but for some reason it is not working as intended.

    Thanks, Moshu
    The setup is done by Install4Free (great help, truly) so I haven’t studied the details.
    Anyhow, I did not touch the index.php file on the root (outside the wordpress folder) since I understood that (among other things) as containing the special setup.
    (After upgrading, I’ve also clicked the Update permalinks because this is required to make the nextgen gallery work properly. It still doesn’t, but i think I’m close to a solution 🙂

    Now, I’ll try to make a new upgrade, then we’ll see.


    DONE – performed new upgrade – BUT I’M STILL LOST
    To log in or out is still impossible, though the rest seems OK

    Now, I’ve carefully just activated plugins found in the 2.3.3 compatibility list
    and also carefully uploaded the different files in correct upload mode

    Any hints would be truly appreciated.


    Hi there,

    I had exactly the same problem. I upgraded to 2.3.3 (from 2.3.2) and deleted the cache folder as instructed. However that was not a good idea. I uploaded the cache folder from a backup file.

    Now most things seem to work fine, however the plugin FeedSmith (FeedBurner) complains about the cache folder:

    “Warning: fopen(/home/managin3/public_html/wordpress/wp-content/cache/wp_cache_mutex.lock) [function.fopen]: failed to open stream: No such file or directory in /home/managin3/public_html/wordpress/wp-content/plugins/wp-cache/wp-cache-phase2.php on line 96”

    Any ideas?

    Thank you!


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Mistake deleting cache folder’ is closed to new replies.