• Resolved jwamsterdam

    (@jwamsterdam)


    Hi,

    Since the last update of Sitekit (1.9.0), I get the following error (missing_delegation_consent) on both my google analytics and search console data.

    I have already removed and reinstalled sitekit, as well as dicsonnected and reconnected to the google servies, but the error persists.

    Are more experiencing this issue and is there any fix?

    Thank you!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    @jwamsterdam Thanks for reporting. So we can investigate this further can you provide the following information:
    1. Your Site Health info
    2. A screenshot of the error message, along with any console errors that appear

    To share your Site Health information you can use this form.

    Thread Starter jwamsterdam

    (@jwamsterdam)

    
    ### wp-core ###
    
    version: 5.4.1
    site_language: nl_NL
    user_language: nl_NL
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /www
    wordpress_size: 1,73 GB (1852872689 bytes)
    uploads_path: /www/wp-content/uploads
    uploads_size: 434,69 MB (455801632 bytes)
    themes_path: /www/wp-content/themes
    themes_size: 36,23 MB (37992823 bytes)
    plugins_path: /www/wp-content/plugins
    plugins_size: 135,12 MB (141682202 bytes)
    database_size: 20,48 MB (21479424 bytes)
    total_size: 2,34 GB (2509828770 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Stockholm Studio (stockholm-studio)
    version: 5.1.8.1570992005
    author: Select Themes
    author_website: http://demo.select-themes.com
    parent_theme: Stockholm (stockholm)
    theme_features: automatic-feed-links, post-formats, post-thumbnails, title-tag, editor-style, menus, StockholmQodeSidebar, widgets
    theme_path: /www/wp-content/themes/stockholm-studio
    
    ### wp-parent-theme ###
    
    name: Stockholm (stockholm)
    version: 5.2.1
    author: Select Themes
    author_website: http://demo.select-themes.com
    theme_path: /www/wp-content/themes/stockholm
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.3, author: het WordPress team
    
    ### wp-plugins-active (20) ###
    
    Asset CleanUp: Page Speed Booster: version: 1.3.6.4, author: Gabriel Livan
    Async JavaScript: version: 2.20.03.01, author: Frank Goossens (futtta)
    Autoptimize: version: 2.7.2, author: Frank Goossens (futtta)
    Cache Enabler: version: 1.3.5, author: KeyCDN
    Duplicator: version: 1.3.34, author: Snap Creek
    Flying Pages by WP Speed Matters: version: 2.4.1, author: Gijo Varghese
    Health Check & Troubleshooting: version: 1.4.4, author: The WordPress.org community
    Leverage Browser Caching: version: 1.9, author: Rinku Yadav
    Mailster - Email Newsletter Plugin for WordPress: version: 2.4.10, author: EverPress
    Post Hit Counter: version: 1.3.2, author: Hugh Lashbrooke
    Redirection: version: 4.8, author: John Godley
    ShortPixel Image Optimizer: version: 4.18.1, author: ShortPixel
    Simple Custom Post Order: version: 2.5.0, author: Colorlib
    Site Kit by Google: version: 1.9.0, author: Google
    Slider Revolution: version: 6.1.5, author: ThemePunch
    Stockholm Core: version: 1.2.1, author: Select Themes
    UpdraftPlus - Backup/Restore: version: 1.16.25, author: UpdraftPlus.Com, DavidAnderson
    WPBakery Page Builder: version: 6.1, author: Michael M - WPBakery.com (latest version: 6.2)
    WP Retina 2x: version: 5.6.0, author: Jordy Meow
    Yoast SEO Premium: version: 14.2, author: Team Yoast
    
    ### wp-plugins-inactive (5) ###
    
    Analytify - Google Analytics Dashboard: version: 3.0.0, author: Analytify
    Analytify Pro: version: 2.1.2, author: WPBrigade
    Search Console: version: 2.0.7, author: Tropicalista
    Site Health Tool Manager: version: 1.1, author: William Earnhardt
    Yoast SEO: version: 14.2, author: Team Yoast
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.101-stretch980030 x86_64
    httpd_software: Apache
    php_version: 7.3.18 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 5000
    time_limit: 120
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 128M
    php_post_max_size: 128M
    curl_version: 7.52.1 OpenSSL/1.0.2u
    suhosin: false
    imagick_availability: false
    server-headers: 
    	date: Mon, 08 Jun 2020 11:18:29 GMT
    	server: Apache
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	content-type: text/html; charset=UTF-8
    	x-transip-backend: web565
    	x-transip-balancer: balancer0
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.1.44-MariaDB-1~stretch
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: https://www.jonnaklumpenaar.nl
    WP_SITEURL: https://www.jonnaklumpenaar.nl
    WP_CONTENT_DIR: /www/wp-content
    WP_PLUGIN_DIR: /www/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### google-site-kit ###
    
    version: 1.9.0
    php_version: 7.3.18
    wp_version: 5.4.1
    reference_url: https://www.jonnaklumpenaar.nl
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    active_modules: site-verification, search-console, analytics, pagespeed-insights
    required_scopes: 
    	openid: ✅
    	https://www.googleapis.com/auth/userinfo.profile: ✅
    	https://www.googleapis.com/auth/userinfo.email: ✅
    	https://www.googleapis.com/auth/siteverification: ✅
    	https://www.googleapis.com/auth/webmasters: ✅
    	https://www.googleapis.com/auth/analytics.readonly: ✅
    search_console_property: https://www.jonnaklumpenaar.nl/
    analytics_account_id: none
    analytics_property_id: none
    analytics_profile_id: none
    analytics_use_snippet: yes
    
    
    Thread Starter jwamsterdam

    (@jwamsterdam)

    Plugin Support James Osborne

    (@jamesosborne)

    @jwamsterdam Many thanks for sharing. I’ve created the following GitHub issue so we can investigate this further.

    In the meantime so we can try and get you connected can you try deactivating and then deleting the plugin in full, before then trying to setup the plugin from a browser incognito window?

    Plugin Support James Osborne

    (@jamesosborne)

    @jwamsterdam Apologies, I didn’t provide the link to the GitHub issue. You can find it below:
    https://github.com/google/site-kit-wp/issues/1646

    Have you had a chance to try the suggested steps mentioned previously?

    Thread Starter jwamsterdam

    (@jwamsterdam)

    @jamesosborne Thank you!

    I have tried the steps you provided, but still get the same error.

    • This reply was modified 4 years, 1 month ago by jwamsterdam.
    Plugin Support James Osborne

    (@jamesosborne)

    @jwamsterdam Thanks for the update. Do you know at any stage did you revoke access to any of the services? Please follow the steps below and inform me whether you can successfully connect to Site Kit:
    1. Open a browser incognito window
    2. Accessing this link, and login with the Google account from which you are setting up Site Kit with
    3. Click on the Site Kit app and then click on the “Revoke Access” button
    4. Login to your site and attempt Site Kit setup once more

    Bear in mind if you have Site Kit setup on any other sites you’ll need to setup Site Kit once more after following the steps above. If you have any questions on the above let me know.

    @jwamsterdam just a quick follow up that we notice a different URL registered on the Site Kit service for your site. Perhaps this part of a security mechanism.

    Is the admin of your site completely accessible from the other URL which is different from the frontend?

    I’ve been getting the same message on a number of my sites. Glad to see you’re on it !

    Thread Starter jwamsterdam

    (@jwamsterdam)

    Hi @reneesoffice I do not understand what you mean. Where can I find this other URL?

    Thread Starter jwamsterdam

    (@jwamsterdam)

    Hi @reneesoffice I performed a Reset Sitekit, by pressing this option in the settings page of SiteKit. After reconnecting, the service now works!

    If any help is needed to find the root-cause of this issue, please let me know.

    @jwamsterdam glad to hear that this helped! Are you familiar with a URL located at: https://s*****.jonnaklumpenaar.nl? That was what we initially had on the service.

    @bkellaway we can assist in your case as well if resetting Site Kit under Site Kit > Settings > Admin Settings > Reset Site Kit does not resolve it for you. Please open a new support topic with details. thanks!

    thanks @reneesoffice Reset Site Kit worked !!!

    @bkellaway that’s great! Thanks for letting us know!

    @jwamsterdam feel free to provide us any additional info at your convenience.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘missing_delegation_consent’ is closed to new replies.