WordPress.org

Forums

Google XML Sitemaps
[resolved] Missing xml tag error (18 posts)

  1. kb331
    Member
    Posted 1 year ago #

    I created my first sitemap with this plugin and added it to google webmaster tools. In my account I went to Crawl > Sitemaps and received the following error:

    Type: Error
    Issue: Missing XML tag
    Description: This required tag is missing. Please add it and resubmit.
    Example: (Sitemap: businessandculturecast.com/sitemap-externals.xml Parent tag: urlset Tag: url)
    Line: 4

    Where is the file? I've searched my database and it doesn't exist there.

    https://wordpress.org/plugins/google-sitemap-generator/

  2. CarolWP
    Member
    Posted 1 year ago #

    The file is not on the server; it's supposed to be generated on the fly when called for. However, I'm having the same issue with the Missing XML tag. I've used this plug-in for a long time, but the issue just started recently.

  3. wolkenkraft
    Member
    Posted 1 year ago #

    I can confirm this error...

  4. duttasanjib2003
    Member
    Posted 1 year ago #

    I just submit sitemap in google webmaster tools and faced the same Missing XML tag problem, any one can help...

  5. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Did you add any custom URLs to the sitemap via the admin panel?

  6. CarolWP
    Member
    Posted 1 year ago #

    No, I did not add any custom URLs.

  7. kb331
    Member
    Posted 1 year ago #

    I only edit the url's from the post or page editor and I've never created a sitemap outside of this plugin.

  8. ZinZang Studio
    Member
    Posted 1 year ago #

    Had same problem, apparently caused by a line in the pre-update robots.txt file.

    Solved for me by deleting the ".gz" at the end of that Sitemap line in the robots.txt file, then resubmitting the sitemap.

    So, instead of "Sitemap: http://yourdomain.com/sitemap.xml.gz", the line is now , "Sitemap: http://yourdomain.com/sitemap.xml"

  9. wolkenkraft
    Member
    Posted 1 year ago #

    I´ve no robots.txt in use...

  10. ZinZang Studio
    Member
    Posted 1 year ago #

    Sorry, I didn't have exactly the same problem as thread starter kb331.
    My problem was with sitemap-archives.xml, fixed by adding a Post (site had only Pages), while "Include archives" was checked in XML-Sitemap Generator settings.

  11. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    For the problems with the -archives.xml: For performance reasons, the plugin currently does not check if you have any posts or not. If this entry causes a problem, you can deactivate the archives in the cotnrol panel of the plugin.

    For the problems with the -externals.xml: Can you try to go to the sitemaps control panel and click the save button at the end of the page? Also make sure there are no empty lines "Additional Pages" section.

  12. Hamza Tariq
    Member
    Posted 1 year ago #

    I am having a issue with the sitemap

    Error Type:Missing XML tag
    Detail:This required tag is missing. Please add it and resubmit.
    Sitemap: http://bossvfx.com/sitemap-pt-post-2013-10.xml
    Parent tag: urlset
    Tag: url

    After checking these two pages should be inside the xml

    How to add these pages inside. I have the access to wordpress site dashboard.

    Plugins I am using:

    • All in One Webmaster
    • Clean Testimonials
    • Customize your 404 Error Page for WordPress
    • Fast Secure Contact Form
    • Google Analytics
    • Google XML Sitemaps
    • kk Star Ratings
    • Page Links To
    • Quotes Collection
    • RA-FB Like Box
    • Royal Side Button
    • RRF Scroll To Top
    • SEO Ultimate
    • ShareThis
    • Social Comments
    • WP Super Cache
  13. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Please try the new 4.0.5beta versiom, I've fixed something regarding missing posts there. Thanks!

    http://downloads.wordpress.org/plugin/google-sitemap-generator.zip

  14. CarolWP
    Member
    Posted 1 year ago #

    It looks like the beta fixed the issue for me.

  15. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    Great, thanks for the feedback!

  16. kb331
    Member
    Posted 1 year ago #

    My original problem still persists after installation of the beta.

  17. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    @kb331:

    Did you try this?

    For the problems with the -externals.xml: Can you try to go to the sitemaps control panel and click the save button at the end of the page? Also make sure there are no empty lines "Additional Pages" section.

  18. ansar nawaz
    Member
    Posted 9 months ago #

    i have the problem in ..

    /video-sitemap.xml

    Errors
    Missing XML tag
    This required tag is missing. Please add it and resubmit.
    1
    Parent tag: urlset
    Tag: url
    4

    http://youtubeck.com/video-sitemap.xml

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google XML Sitemaps
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic