Support » Plugin: Yoast SEO » Missing XML tag

Viewing 7 replies - 1 through 7 (of 7 total)
  • Having exactly the same issue, not found a fix yet either 🙁

    I’m having the same problem with Google Webmaster Tools. Any ideas how to resolve this?

    Forgive the lengthy post. It is fixed for me now and I’m no longer getting the Missing XML Tag on Google Webmaster Tools (GWT). I’m not exactly sure “what” fixed it, but here are some steps I took… maybe someone else can glean something from it 🙂

    In my case, on GWT, the error was referring to the “Category” and “Post_Tag” xml’s. Also, it indicated on both that there was an error on LINE #3 of the xml’s.

    I didn’t have any Categories or Posts (all my pages are static) so I added one of each. In SEO/SiteMaps, I clicked the XML Sitemap button and could view my Sitemap, including sub-maps for the Category and Post_Tag and could open & view each of them independently in the browser.

    Back to GWT, tried resubmitting the sitemap but it resulted in the same error.

    I then went into SEO/ExcludeTaxonomies and placed checkmarks next to Categories & Tags. Save Changes. Clicked XML Sitemap and this time it did not generate the Category and Post_Tag sub-maps.

    Back to GWT, resubmitted, but STILL had the same problem. I don’t know “what” GWT was seeing. Were there leftover xml’s for those two sub-maps? (note: I’m not using a wordpress cache plugin)

    I installed the Plugin “Google XML Sitemaps”, generated its Sitemap, and was able to submit it successfully at GWT. Tried YoastSEO’s Sitemap again and still no joy.

    Back to SEO/ExcludeTaxonomies, removed checkmarks, saved, resubmitted, same problem at GWT.

    Finally, back to SEO/ExcludeTaxonomies, placed checkmarks back on Categories and Post_Tag, saved, resubmitted to GWT and all was well this time.

    So, again, I’m really not sure “what” fixed it. I wonder if it was toggling the ExcludeTaxonomies check boxes (saving in between) that did it.

    GWT definitely did not like line #3 in both the Categories.xml and Post_Tag.xml

    I had a similar problem with Yoast, but I guess a bit simpler since my fix was easier.

    The error that I got in Webmaster Tools referenced the Post_Tag.xml. I realized that the site I was looking at wasn’t even using “tags” on their blog, so I went into Yoast SEO settings and just checked off the Tags (post_tag) under Exclude Taxonomies and saved changes. At Webmaster Tools I resubmitted my sitemap and it worked perfectly fine.

    I didn’t need to do anything other than what’s noted above, and I’m not a dev, so maybe this is an easy fix for people with a similar problem who are not so technical?

    Getting this error too..

    Basically only happens when the sitemap is empty – in my case it was for a custom taxonomy…

    I guess the way the mark-up is generated is dependant on there being at least 1 results…. My work around as above was applying the taxonomy arbitrarily to a post.

    Same for me, empty category was causing XML error

    Same Problem 😀

    Missing XML tag
    This required tag is missing. Please add it and resubmit.
    Parent tag: urlset
    Tag: url

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Missing XML tag’ is closed to new replies.