Support » Plugin: Duplicator - WordPress Migration Plugin » Missing wp_users entry from database when moving

  • Resolved cbhurji

    (@cbhurji)


    Hi,
    I have just joined your support group to solve and issue that I have spent lots of time to resolve.
    In short: I have used duplicator within WP, to export my website to a live host server several times in the past and been OK, however recently after some additional changes in my website, I carried out the same duplicator procedure but received an β€œError 500” on the hosting server. The current service provider support team are looking into this, but they do not seem very helpful or do I believe that they will be able to help in reasonable timescale.
    Therefore, I thought I would start testing the basics on my own on the localhost server (I am using WAMPServer 3.0.4 and Duplicator Version 1.1.18). I want to take the packaged files from duplicator and pretend installing, but to a different directory, but doing this all on the localhost if you see what I mean. I went through the correct motions of packaging and then re-installing onto a different directory and a new database. The WP files and the database gets installed, but at the end of the install, instead of login to WP automatically (as on live server) and allow saving of permalinks, the installation puts up the WP login dialog asking me to login into WP, as if there is no user credentials?? I have taken the same packaged files on to live server and this issue does not occur, but eventually ends, as mentioned into Error 500
    Back to my localhost testing: I then checked the database and noticed that I do not have wp_users entry created automatically within the test database! As mentioned, this entry is somehow extracted correctly and WP find correct user and login. I am certain if I can work out how to create an entry for wp_users correctly that my localhost testing could proceed further (some help here would be great as well on how-to do this). Why is this entry missing (wp_users) when testing the installer files from duplicator on localhost and what is the work-around please?

Viewing 11 replies - 16 through 26 (of 26 total)
  • Hi cbhurji,

    for your latest post, I also tried out all these steps, even before reading your post (sorry for that); but i get a FINAL result as all site is on left side of the page and no more sweet look of the site…..i dont know why it happens BUT it does!!!

    during the run of installer, i also move to phpmyadmin,make a new db, dropping the already made one(empty and necessary for duplicator to fill in the sql file querries from zip) and then import the sql file that i get from duplicator and that successfully gets all the tables and let me in to the site as well, on localhost, as it finds the wp_users and wp_posts tables BUT THE PROBLEM IS that my site looks get disturbed which were ok if i had done with the routine process of duplicator?????

    The ONLY solution (i would appreciate your help in this regard though! ) is to allow duplicator to do its process, as it will not disturb the looks of my site and then go back to compare the tables from the ORIGINAL sql file and the ones in database in phpmyadmin, filled by duplicator……….this would take time but HOPEFULLY will solve it!!!!!

    thanks and waiting for any views!

    I am sorry but I don’t seem to quite fully understand what you are stating in first or second paragraph

    If it was not clear then here it is again:
    You run installer..blah..blah.php on the live or localhost and PAUSE at the point of path replacement. Go into phpadmin; select ALL entries in your DB (remember this the DB that the current installer has just overwritten into); perform DROP on ALL; open your original SQL packed by either you OR Duplicator (either will work); Perform IMPORT and you will get back all your entries; If you care to note the number of entries BEFORE DROP and after IMPORT you will see a discrepancies, proving bug in plugin; now go back to PAUSED installer script and run to end and let it completely

    This has worked 100% for me and I have done it over 50times by now (frantic webpage designs). I do like the simplicity of the plugin and cannot be arsed to go find another (YET!). I have informed the designer of this issue and he has NOT bothered to reply back. I have upgraded with all his latest bug fixes and can still confirm it is BROKEN but my manual intervention still works for me so I made it my norm regardless of the updates from designer πŸ™‚

    Try exactly what I am suggesting (do not deviate with your own) and see you get on with it

    Hi cbhurji,

    I have to thank you many times over for the debugging of this and putting up a solution here.

    I too had exactly the same problem – same machine, same software, etc – and kept getting the same error as you did; when performing the final steps of the Duplicator installation, which is to change the permalinks, I kept getting an error when trying to login into WordPress.

    This of course was due to the Duplicator plugin not installing the wp_users table (as well as others), precisely as you had discovered and relayed in your posts to the developer early on.

    I followed your steps and so far have managed to install two duplicate websites successfully since. I would have been lost without your guidance here, so thank you very much for helping and contributing to the community.

    I encourage everyone to take cbhurji’s advice and first load a copy of the sites DB into PhpMyadmin first to take note of the Databases original row count.

    Then after Duplicator re-fills the DB with its version, before the search and replace of URLS, go into PhPMyAdmin again and check the row count then.

    I can assure you its probably less than the original DB, if so, DROP all tables, and once again import your original backed up .sql file.

    Then resume Duplicator Installation. All should work then.

    Great work cbhurji!! I hope the developer of this plugin can use this info and your debugging to fix this in the future πŸ™‚

    Hey
    I glad it works for you as well, which reassures that it is not something to do with my setup.

    To be perfectly honest I got so used to doing these steps, that I don’t bother doing it the ‘norm’ way anymore πŸ™‚

    wavespark7425

    (@wavespark7425)

    Thank you, @cbhurji.

    I experienced the very same issue moving a site from live-server to localhost.

    Your detailed instructions saved me from many more hours of frustration.

    Much appreciated!

    I’m having the same issues, but the import of the duplicator sql file fails to bring in wp_users. I paid for a pro version of this https://wordpress.org/plugins/wp-migrate-db/ which is pricey but works well. Duplicator’s setup for install is faster, but I will likely just go back to my old work flow at this point.

    I was dealing with small and light weight sites and never encounter such problem, but today when I migrate a 1.4gb site there’s a lot of issue, I can’t even logging, even after I copy the wp_user table, it just redirect me to the homepage but not the admin dashboard.

    And is there anyway to split the archive zip file that Duplicator can recognise to extract them?

    • This reply was modified 2 years, 10 months ago by washiwed.

    have experienced no wp_users also on import and found a workaround.
    so after FINISHING the whole duplicator installer.php steps (but not closing the page), i then get the sql file out of the package, open a new tab for phpmyadmin, drop all the tables in the database, and import the sql file directly. i then go to the installer tab and go ‘back’ in the browser so i can do the find/replace to make it match the new location.

    100% success so far.

    the ‘issue’ is a bug somewhere in the reinstall / installer.php because the sql is fine.

    in installer-log.txt i see these errors:

    **ERROR** database error write ‘Invalid default value for ‘comment_date” – [sql=
    CREATE TABLE wp_comments (
    comment_ID bigint(20) unsigned NOT NULL A…]
    **ERROR** database error write ‘Invalid default value for ‘created” – [sql=
    CREATE TABLE wp_duplicator_packages (
    id bigint(20) unsigned NOT NUL…]
    **ERROR** database error write ‘Invalid default value for ‘link_updated” – [sql=
    CREATE TABLE wp_links (
    link_id bigint(20) unsigned NOT NULL AUTO_IN…]
    **ERROR** database error write ‘Invalid default value for ‘post_date” – [sql=
    CREATE TABLE wp_posts (
    ID bigint(20) unsigned NOT NULL AUTO_INCREME…]
    **ERROR** database error write ‘Invalid default value for ‘user_registered” – [sql=
    CREATE TABLE wp_users (
    ID bigint(20) unsigned NOT NULL AUTO_INCREME…]
    **ERROR** database error write ‘Table ‘core.wp_comments’ doesn’t exist’ – [sql=

    same problem here, Duplicator has too many bugs, not working with live host to local wamp , I used all-in-one wp migration https://wordpress.org/plugins/all-in-one-wp-migration/#description , it works like a charm

    • This reply was modified 2 years, 10 months ago by augustodc.

    I use a sub-directory for WordPress and when I upload with Duplicator \ is missed.
    My Duplicator version is 1.2.14
    My WordPress is 4.7.5
    I tried all other the ‘duplicate/migrate/clone’ plugin. All failing.
    Now I will try to install a fresh wordpress to my live-site and so
    to attempt with any ‘backup/dropbox’ plugin.

    edit —-

    I managed to solve it for myself, locally, using WAMP local server. Not sure how this fix might be applied to a live site, but it worked for my issue.

    1. Open this file in notepad: C:\wamp64\bin\mysql\mysql5.7.9\my.ini
    2. Add the final line to the file:
    [mysqld]
    port = 3306
    sql_mode=NO_ENGINE_SUBSTITUTION

    (then restart WAMP)

    —- end edit

    I have the same issue with duplicator, I believe it is dropping more than just the users table, as I have tried just importing the missing table and the site media uploads was broken.

    Its a shame that I can’t figure out why duplicator doesn’t work anymore. Its not flagging any issues with installation, yet it doesn’t work on any site I try. Its a pain that I now need access to a website’s PhpMyAdmin now to get the proper database export.

    • This reply was modified 2 years, 9 months ago by niahc.
    • This reply was modified 2 years, 9 months ago by niahc. Reason: found a solution
Viewing 11 replies - 16 through 26 (of 26 total)
  • The topic ‘Missing wp_users entry from database when moving’ is closed to new replies.