Support » Fixing WordPress » Missing Visual Editor

  • I’m running wp3.1.3, testing with Firefox, IE and Chrome, and all browsers showed the error. My website/blog is

    Since upgrading to 3.1.3, my visual editor went missing. When I click the Visual tab, which is still there and “live”, it would give me the html editor with the button bar removed instead of the visual editor. I’ve spent days reading older posts in this forum from many people who’ve had the same problem in the past. The vast majority of them had a long list of things to try, which the people would try, but they wouldn’t work, and someone would close the topic as “resolved” without any real solution being posted. Others were closed as “resolved” as soon as the question was asked, with no answer posted. The few people who did have some success in getting their editor back, however, did so by discovering an interfering plugin.

    This morning, I tried disabling all of my plugins (I run Atahualpa as my theme, and my entire site pretty much depends on the theme structure, and wouldn’t run without it–it’s upgraded to the latest version each time a new version comes out), and have quite a few plugins I depend on. I then re-enabled the plugins, one at a time, and tested for the visual editor after each one was enabled. The visual editor reappeared and worked properly after enabling all but THREE of the plugins. The three plugins that broke the editor (and unfortunately a couple of them have been essential to the site for some time, though the third I can do without) are:

    Jetpack by
    NextGEN Gallery

    I can do without the polls, but both the NextGEN gallery and Jetpack are important to the running of my site in many ways.

    I’ve posted this here in the hopes that there is “something in common” between these three plugins, and this will help the developers to figure out what it is about them that breaks the visual editor in WordPress 3.1.3.

    AND: Are there other plugins, that actually work without breaking anything, that I may use as substitutes for the above? I’m told there’s no way to access stats, which are invaluable, without Jetpack any more, is this true?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Are there other plugins, that actually work without breaking anything, that I may use as substitutes for the above?

    you could just make your own.

    I would search out each plugin within the forums and see if any problems like this have been found.

    I don’t find any other posts about those particular plugins connected to the visual editor breakage. However, each of them, when I re-enabled just that one, caused the editor to disappear again. It works fine when those three are disabled. This is only happening since the 3.1.3 upgrade (reinstalling WordPress did not help).

    Update: I’m finding other problems as well. I attempted to reactivate NGGallery, for instance, and find that not only does it still break the visual editor, it no longer works at all. All I get is a vertical listing of thumbnails (not how it’s set to display), and clicking on each leads to the photo itself in the same tab, but none of the normal navigation tools, the slideshow does not work, etc. I tried installing another photo gallery plugin (1 Flash Gallery) and cannot create a gallery with it at all, I fill in settings and click Save and it sends me an error message that /index.php/404 cannot be found on the server (among other things).

    Then, this morning, I received the notification about the hack into various plugins (none of which are the ones causing my problems, nor do I have any of the suspect ones installed) and I’m wondering if this is wider spread than initially thought, and my issues may be related to this backdoor. If it’s just a coincidence that they appeared around the same time, it’s an odd one.

    And thank you mdevaney, but not everyone is a plugin programmer.

    Moderator kmessinger


    I’m told there’s no way to access stats, which are invaluable, without Jetpack any more, is this true?

    I use the Atahaulpa theme also. And I use and not jetpack.

    You might also try, for help with NGGallery.

    Hi, Kmessinger, I used to use that stats plugin, but it stopped working, and searching here revealed several threads saying that you had to install Jetpack if you wanted to get stats from, that the one you link to above was no longer valid.

    Both are now currently disabled on my site, because neither work.

    I don’t see anything about NGGallery on the hotfix link…? Looks like it updates bugs in the core system?

    Moderator kmessinger


    It stopped working when was having some problems. Most people couldn’t wait so they went to Jetpack. I use stats on 3 sites, 2 running Atahaulpa with no problems.

    BTW, on one site, I did update jquery.js,, to the latest with no problems. I thought since 99% of the plugin problems are a result of javascript errors it wouldn’t hurt. The update did not break anything.

    NGGallery is mentioned here, with the hotfix. I don’t think running it can hurt anything.

    I am on a fresh 3.1.3 install with no plugins active and I am experiencing the same issue with my visual editor. This should never happen.

    Psyber, on searching forums, this seems to have been an issue that has baffled people intermittently for a while. Many reply that disabling certain plugins (all different ones) restores the editor, but others, like you, have the same issue without any plugins active at all.

    Nothing I’ve done has fixed the problem (other than disabling those three plugins), and attempting to install a different plugin that does the same service (like a different photo gallery other than NGGallery) has been unsuccessful, I’ve been unable to get any of them to work, getting various different error messages when I attempt to use them.

    Upgrading to 3.1.3 “did something” to the basic WordPress installation that it would take a rocket scientist to find and fix, it appears.

    I do thank folks for the various suggestions, but to date, none of them have helped. My website is only about 80% functional, as many of my blog posts depend on photos.

    Moderator kmessinger



    Since upgrading to 3.1.3, my visual editor went missing. When I click the Visual tab, which is still there and “live”, it would give me the html editor with the button bar removed instead of the visual editor.

    Is this what is happening to you? If not please start another thread.(


    Did you try the hotfix? Also you do apparently have a couple of div problems, that occur near calls for javascript.

    kmessinger, I attempted to install the hotfix, but it took me to a page where I had to type in my URL and click Install. After that, was a page asking if I wanted to install it on, but no way to say Yes or No — just text on a blank page.

    I’d planned to go into my Dashboard and search for it in the plugins directory but haven’t gotten around to it yet.

    I have to confess, I haven’t a clue what all of those errors on the validator mean. Nothing in my site was programmed by me, it’s all standard WordPress 3.1.3 installation plus plugins. If there are that many errors, I haven’t any idea why. I’m not a programmer, just an end user.

    Thanks for trying to help.

    I am having the same issue. I just upgraded to 3.1.3 and now the visual editor is missing, with 3 broken image placeholders in its place. This was a fresh install from a few weeks ago that I had not touched until today. I tried the automatic reinstall, deactivating all plugins, quitting browser, logging out, and clearing cache – all without success.

    Sorry to hear that, bconstant. It does sound like this is a widespread issue caused by the 3.1.3 upgrade. There are so many different “causes and fixes”, though, and nothing consistent.

    Moderator kmessinger


    Your description is not the same. Pls start your own thread.

    I have tried everything suggested. I have attempted to install other gallery plugins only to be told by WordPress that (through various error messages) new galleries cannot be created (they usually go something like:
    No input file specified.
    Not Found

    The requested URL /index.php/404 was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    That one was for 1 Flash Gallery. I’ve tried to contact the plugin developer, only to send the requested information and never hear from them again.

    I’ve upgraded to 3.1.4 and 3.2 when available.

    Nothing has helped.

    If any of those listed plugins above are activated, the visual editor vanishes, to be replaced by a dumbed down version of the html editor.

    Attempts to install the ‘hotfix’ suggested above fail.

    I’m at a total loss and a good chunk of the functionality of my site is missing. My livelihood centers around my website.

    Very discouraged.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Missing Visual Editor’ is closed to new replies.