WordPress.org

Support

Support » How-To and Troubleshooting » Missing Visual Edit Buttons – Cannot type in text box

Missing Visual Edit Buttons – Cannot type in text box

  • I just was forced to upgrade to the newest update on my wordpress blog. The visual edit buttons are gone, and I cannot type in the text box. Tried deactivating plugins, restarting coming, logging out and nothing is fixing it.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Josh

    @josh401

    Moderator and Editor Customizer

    Lets try this:

    1. Deactivate ALL plugins.
    2. Switch to the TwentyTwelve default theme.
    3. Manually empty and refresh your browser cache.

    These three steps are VERY important. Perform these three steps.. then post back here and let us know if you are able to access the editor correctly.

    WPyogi

    @wpyogi

    Forum Moderator

    Try deactivating ALL plugins and switching to the twentytwelve theme.

    Also make sure you’ve cleared any caching on your site.

    What if I have a custom theme on my blog? Will this ruin anything?

    Josh

    @josh401

    Moderator and Editor Customizer

    I can’t say for sure.

    I would take a backup of both the database and the file directories, if you are unsure.

    Did all that, and even re-installed it and nothing worked!

    WPyogi

    @wpyogi

    Forum Moderator

    You switched to twentytwelve with ALL plugins deactivated? Can we see that?

    Yes all 17 of my plugins have been deactivated and I switched over to the theme, logged off, cleared my cache, logged back in and still the same exact thing. I have no switched back over to my custom theme, and plugins are still deactivated and it still doesn’t work

    esmi

    @esmi

    Forum Moderator

    Can we see the site using the default Twenty Twelve theme with all plugins deactivated?

    Josh

    @josh401

    Moderator and Editor Customizer

    Hmmm… perhaps this is something with hosting? I just today had a client with a very similar issue. I logged into the admin, deactivated all plugins, switched the theme to default, emptied cache… and nothing.

    The thing that did the trick was adding this line to the wp-config.php file:

    define('CONCATENATE_SCRIPTS', false);

    Then… everything loaded properly and we were smooth sailing!!

    @divadesirae… are other parts of your admin panel working? For example, if you go to your widget admin screen… and try to drag a widget to one of the available widget areas… are you able to actually “drag” the widget?

    If not.. then it is def a javascript issue.. and I bet the method explained above will fix it for you as well.

    Simply add the single line of code to your wp-config.php file… just above the end of the document where it says something like “That’s it.. stop editing here”.

    EDIT: Out of personal curiosity.. who is your hosting provider?

    @josh – Where do I find the wp-config file? I am not website editing savy thats why I had someone do it for me!

    DreamHost is my provider unfortunately!

    Josh

    @josh401

    Moderator and Editor Customizer

    You will need to use either FTP or your hosts cPanel’s file browser, to access the file directories of your WP site.

    Once you are in the root of your WP site, you will see the wp-config.php file.

    You need to be careful when editing the file; meaning use a code editing software. Notepad++ is a nice, free solution.

    You can learn more about FTP here:
    http://codex.wordpress.org/FTP_Clients

    I have the same issue. I thought I was updating a plugin and all of a sudden WP updated — to 3.5.2

    Now the Visual/Text things seem to be non functional and Tags are flaky, Quick Edit doesn’t work properly, etc.

    I am loathe to dump all the custom programming and Thesis theme etc. which seem to be required of I use the switch to 2012, deactivate the plugs etc

    I run SuperCache — maybe if I clear that?

    The site is POCHO

    adding

    define(‘CONCATENATE_SCRIPTS’, false);

    to wp-config, logging out and logging back fixed things

    *phew*

    spoke too soon

    when I want to add a link, I highlight the text, click on the link button, and the entire screen goes gray with a lightbox/takeover thing and nothing works

    Other editors on my site are reporting the same ‘link’ issue. Anyone?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Missing Visual Edit Buttons – Cannot type in text box’ is closed to new replies.
Skip to toolbar