Support » Plugin: WordPress Popular Posts » Missing thumbnails

  • Resolved Stegemüller

    (@stegemueller)


    Hi Hector

    Suddenly WPP did not show anything, though it was collecting lots of data (I could see that in the tables in phpMyAdmin). I had not changed any settings.

    In a previous post your advice was “Try disabling WPP’s Ajaxify Widget option (Settings > WordPress Popular Posts > Tools, under Data) and see if that helps.”

    I followed that, and data are now shown – except thumbnails. Where did the thumbnails go?

    My setup: WP 5.7.2., PHP 8, Theme: Enfold child.

    Kind regards,
    Hanne B. Stegemüller,
    Denmark

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Héctor Cabrera

    (@hcabrera)

    Hi @stegemueller,

    Suddenly WPP did not show anything, though it was collecting lots of data (I could see that in the tables in phpMyAdmin). I had not changed any settings.

    Sounds like either a caching issue and/or a conflict with another plugin. Maybe these FAQs can help:

    Where did the thumbnails go?

    Hard to say what’s going on without more details. Try following these suggestions and see if that fixes the problem: My popular posts thumbnails are not loading. Why is that?

    If none of that helps then please follow these troubleshooting instructions and report back your findings: I need help with your plugin! What should I do? (Read from the second paragraph and on).

    Thread Starter Stegemüller

    (@stegemueller)

    Hi Héctor

    Thanks a lot for your very kind and quick answer!

    I tried to follow you advice in the FAQ’s, but I must have cleared some wrong cache, as I ended up deleting all rows in popularpostssummary table 🙂 (I did NOT use “clear all data”) and of course I got the message: “Sorry. No data so far.” I have repaired that with importing the 2 tables from my subdomain where I keep a working copy and where WPP works like a dream: https://subdomain.stegemueller.dk/ The subdomain was updated yesterday and has exactly the same plug-ins as the live site.

    I have read all the material you refer to, but I am sorry I could not fix the problem myself.

    I use Hummingbird, and have followed this advice: “If you’re using the Hummingbird plugin by WPMU DEV head to Hummingbird > Asset Optimization, then under Configuration > Exclusions click on File exclusions, select the wpp-js option and click on Publish Changes. When you’re done, go to Hummingbird > Caching > Page Caching and click on the Clear Cache button so these changes are applied to your website right away.”

    In WPP: I’ve set Lazy load to “No”. I’ve tried to “Empty image cache”. I’ve tried to both enable and disable “Ajaxify widget”.

    I am on PHP 8 on both the live site and the subdomain.

    I get this message on both sites “The optional module, imagick, is not installed, or has been disabled.” I do not know how to install it myself. It looks to complicated.

    Maybe it is completely overkill but I do not know what info you need, and therefore I insert informations from the plug-in called “Sitehealth” below.

    Thanks for any kind of help!

    Kind regards,
    Hanne B. Stegemüller

    
    ### wp-core ###
    
    version: 5.7.2
    site_language: da_DK
    user_language: da_DK
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 3
    dotorg_communication: true
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Enfold Child (enfold-child)
    version: 1.0.0
    author: Michael Storm
    author_website: http://designunivers.dk
    parent_theme: Enfold (enfold)
    theme_features: core-block-patterns, avia_exclude_bbPress, deactivate_tribe_events_calendar, avia_exclude_GFForms, avia_exclude_menu_exchange, avia_exclude_relevanssi, avia_exclude_WooCommerce, avia_exclude_wpSEO, avia_exclude_wpml, avia_exclude_instagram_feed, avia_mega_menu, avia_improved_backend_style, avia_option_pages_toggles, avia_sidebar_manager, automatic-feed-links, nav_menus, menus, widgets, post-formats, avia-disable-default-shortcodes, avia_post_meta_compat, force-post-thumbnails-in-widget, post-thumbnails, title-tag, editor-styles, editor-style, customize-selective-refresh-widgets, responsive-embeds, editor-color-palette, editor-font-sizes
    theme_path: /home/stegemue/public_html/wp-content/themes/enfold-child
    
    ### wp-parent-theme ###
    
    name: Enfold (enfold)
    version: 4.8.3
    author: Kriesi
    author_website: https://kriesi.at
    theme_path: /home/stegemue/public_html/wp-content/themes/enfold
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.3, author: af WordPress-holdet
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.2
    
    ### wp-plugins-active (23) ###
    
    Advanced Editor Tools (previously TinyMCE Advanced): version: 5.6.0, author: Automattic
    Akismet Anti-Spam: version: 4.1.9, author: Automattic
    Classic Editor: version: 1.6, author: WordPress Contributors
    Conditional CAPTCHA: version: 4.0.0, author: Samir Shah
    Easy FancyBox: version: 1.8.18, author: RavanH
    Featured Images in RSS for Mailchimp & More: version: 1.5.8, author: 5 Star Plugins
    Head, Footer and Post Injections: version: 3.2.2, author: Stefano Lissa
    Health Check & Troubleshooting: version: 1.4.5, author: The WordPress.org community
    Hummingbird Pro: version: 3.0.1, author: WPMU DEV
    Leaflet Map: version: 2.23.3, author: bozdoz
    Limit Login Attempts Reloaded: version: 2.22.1, author: Limit Login Attempts Reloaded
    MC4WP: Mailchimp for WordPress: version: 4.8.5, author: ibericode
    OG: version: 2.9.0, author: Marcin Pietrzak
    Optimize Database after Deleting Revisions: version: 5.0.4, author: CAGE Web Design | Rolf van Gelder, Eindhoven, The Netherlands
    Simple Author Box: version: 2.3.22, author: WebFactory Ltd
    Simple Custom CSS and JS: version: 3.36, author: SilkyPress.com
    Smush Pro: version: 3.8.7, author: WPMU DEV
    Swap Google Fonts Display: version: 1.0.6, author: Gijo Varghese
    TablePress: version: 1.13, author: Tobias Bäthge
    UpdraftPlus - Backup/Restore: version: 2.16.58.25, author: UpdraftPlus.Com, DavidAnderson
    WordPress Popular Posts: version: 5.3.3, author: Hector Cabrera
    WPMU DEV Dashboard: version: 4.11.0, author: WPMU DEV
    XML Sitemap & Google News: version: 5.2.7, author: RavanH
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-962.3.2.lve1.5.38.el7.x86_64 x86_64
    httpd_software: LiteSpeed
    php_version: 8.0.6 64bit
    php_sapi: litespeed
    max_input_variables: 1000
    time_limit: 14400
    memory_limit: 1024M
    max_input_time: 1000
    upload_max_size: 256M
    php_post_max_size: 256M
    curl_version: 7.74.0 OpenSSL/1.1.1k
    suhosin: false
    imagick_availability: false
    server-headers: 
    	server: Sucuri/Cloudproxy
    	date: Sun, 20 Jun 2021 16:50:35 GMT
    	content-type: text/html; charset=UTF-8
    	x-sucuri-id: 19014
    	x-xss-protection: 1; mode=block
    	x-frame-options: SAMEORIGIN
    	x-content-type-options: nosniff
    	strict-transport-security: max-age=31536000; includeSubdomains; preload
    	content-security-policy: upgrade-insecure-requests;
    	set-cookie: aviaPrivacyMustOptInSetting=false; expires=Sun, 20-Jun-2021 15:50:34 GMT; Max-Age=0; path=/; SameSite=Strict; secure
    	expires: Thu, 19 Nov 1981 08:52:00 GMT
    	cache-control: no-store, no-cache, must-revalidate
    	pragma: no-cache
    	link: Array
    	vary: Accept-Encoding,User-Agent
    	content-encoding: gzip
    	x-turbo-charged-by: LiteSpeed
    	x-sucuri-cache: BYPASS
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.29-MariaDB-cll-lve
    client_version: mysqlnd 8.0.6
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/stegemue/public_html/wp-content
    WP_PLUGIN_DIR: /home/stegemue/public_html/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Plugin Author Héctor Cabrera

    (@hcabrera)

    Thanks for the additional info Hanne, that was very helpful.

    I took a closer look at your website and I’m pretty sure that the problem is being caused by Smush Pro’s image lazy loading. Another user reported a very similar problem not too long ago: Smush stopping images loading. Try following the suggestions I left there and check again.

    I get this message on both sites “The optional module, imagick, is not installed, or has been disabled.” I do not know how to install it myself. It looks to complicated.

    That’s OK, you don’t really need worry about it. The imagick module is optional and not having it installed on your website won’t cause any issues since you do have the GD module (another image processing module) installed. It would be a problem if neither of them were installed 😛

    If you still want to get imagick working on your website though then you may want to consider reaching out to your hosting provider and have them take care of it for you.

    Thread Starter Stegemüller

    (@stegemueller)

    Héctor – you are not less than my hero of today.

    That simply solved the problem, and my site look perfect again. Thank you so much.

    All the best.

    Hanne B. Stegemüller,
    Denmark.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Missing thumbnails’ is closed to new replies.