Support » Plugin: PayPal for WooCommerce » Missing the order number on PayPal confirmation email when using PayPal Plus

  • Thank you very much for this awesome plugin. I have a question concerning the confirmation email that the shop owner gets directly from PayPal whenever someone is buying something using PayPal. I need to have the order number written on that email. For PayPal Express checkout the order number is written on the PayPal receipt however not for PayPal Plus. How could I add the order number to the PayPal confirmation?

    Thank you in advcance!

    https://wordpress.org/plugins/paypal-for-woocommerce/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Contributor angelleye

    (@angelleye)

    Unfortunately, I don’t think there is anything we’ll be able to do about that. We are already including the order number in the API requests involved with the PayPal Plus checkout, so if it’s not showing up on the email receipt that is something PayPal themselves would have to adjust.

    Can you check the transaction details page from a WooCommerce order in PayPal to see if the order number is showing up there?

    Thank you for your answer. The weird thing is that the order number is not showing up in PayPal when I check my transaction page. It is however for PayPal Express. Is it possible that the order number is not being sent to PayPal for PayPal Plus? Could you tell me in what plugin file the request is sent to PayPal when using Plus and in what file when using Express?

    Thank you!

    Plugin Contributor angelleye

    (@angelleye)

    Please download this copy and update it manually to see if the order ID shows up then.

    I’m pretty sure we got this resolved in that copy, which is about to be released as the 1.2.0 update.

    When I upload this copy I get the following error:

    Gateway Disabled: PayPal does not support your store currency.

    As store currency Euro (€) is chosen.

    Plugin Contributor angelleye

    (@angelleye)

    You’re getting that in PayPal Plus with EUR set as your currency?? That’s odd. I’ll have to double check that…

    When I upload the files from your link and then reactivate the plugin I get the above error. It’s telling me to add some PayPal Merchant login (I think it was called something like that) and when I click on the link “Login” the error appears. So the error seems to be not specifically PayPal Plus related.

    Plugin Contributor angelleye

    (@angelleye)

    Are you sure that message isn’t coming from PayPal Advanced?

    First, if you have updated to WordPress 4.5, download the release branch version again. It now contains a patch for some deprecated functions in 4.5.

    Once you’re up and running with that, if it’s still happening, change the WooCommerce currency to USD for a moment, and then go into the PayPal Advanced settings and make sure it’s disabled…and save it.

    Then switch back to EUR and I think that issue will go away.

    Thank you for your help. I did as you said, PayPal Advanced was indeed switched on after I uploaded the new version of your plugin. So I changed the currency to USD, then switched PayPal Advanced off and changed the currency back to EUR. However the error message telling me to login to PayPal Advanced is still there. I double checked but PayPal Advanced is surely switched off.

    I just wrote to my client asking whether the order number is now on the PayPal receipt, I will get an answer soon.

    EDIT: I just realized that there are in fact two error messages! The first one saying

    Paypal Advanced error: Please enter your PayPal Advanced Account Merchant Login

    And the second one saying

    Gateway Disabled: PayPal Plus does not support your store currency (Supports: EUR, CAD).

    (I double checked, the store currency is for sure Euro)

    Just got news from my client. There is indeed an order number on the receipt now. However what he wants is the number to be the invoice number, not the order number. Could you tell me where I could adapt what is being sent to PayPal and replace the order number with the invoice number?

    Plugin Contributor angelleye

    (@angelleye)

    Where exactly are those error messages showing up? I’m a little confused. Can you provide a screenshot?

    Ok the second error message is gone now, but the first one remains (screenshot: https://pl.vc/4v2og )

    Could you please tell me how to change the order number to invoice number?

    Thank you

    Oh the second error isn’t gone. When I click on the link in the screenshot above (where it says Login here) I get to the following screen: https://pl.vc/34mjr

    Plugin Contributor angelleye

    (@angelleye)

    It would make sense that PayPal Advanced would give you that error when you are set to EUR because it is not compatible with that currency. Is it actually causing any problem for you on the front end of the site during checkout?

    I’ll see about whether or not we need to make an adjustment to get that notice about credentials for Advanced to go away when viewing Plus. That’s odd you’re seeing that, but again, that shouldn’t cause any problem with the front-end of the site or checkout. Please confirm.

    It seems not to cause any problem in the frontend, site or checkout, it’s just weird that it’s showing the error although PP Advanced is turned off.

    Could you please provide me with a hint where I could change the order number sent to PayPal to be the invoice number?

    Plugin Contributor angelleye

    (@angelleye)

    Right now there is no hook available to change that, so you’d have to do it in the core code, which is not generally recommended, but if you want to do that you can open up the payflow class file (in the classes directory of the plugin structure) and within that you can find where the orderid is getting set.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Missing the order number on PayPal confirmation email when using PayPal Plus’ is closed to new replies.