Support » Installing WordPress » missing the MySQL….

  • Resolved ArthurDent


    Hi all.

    I am trying to install WordPress on a Fedora Core 5 system. I have MySql and PHP.

    I’ve been carefully following the Installation instructions. I’ve set up a MySql DB which I’ve checked works as follows:
    $ mysql -u wordpress -p
    Enter password: mypass
    Welcome to the MySQL monitor. Commands end with ; or g.
    Your MySQL connection id is 6 to server version: 5.0.22

    Type 'help;' or 'h' for help. Type 'c' to clear the buffer.

    mysql> SHOW DATABASES;
    | Database |
    | information_schema |
    | blog |
    | test |
    3 rows in set (0.02 sec)

    and this is my wp-config.php file:

    // ** MySQL settings ** //

    define(‘DB_NAME’, ‘blog’); // The name of the database

    define(‘DB_USER’, ‘wordpress’); // Your MySQL username

    define(‘DB_PASSWORD’, ‘mypass’); // …and password

    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    But when I try to run the installation script I get the following:
    Your PHP installation appears to be missing the MySQL which is required for WordPress

    Actually it says “catYour PHP installation appears to be missing the MySQL which is required for WordPress”

    I have googled and searched this forum. Most answers to this seem to require adding the line :
    to the bottom of my php.ini file (which I’ve done). Still no joy.

    So then I tried this : I created a “test.php” file with <?php phpinfo(); ?> in it. When I run that from the browser it gives me (amongst much else)

    ./configure' '--build=i386-redhat-linux' '--host=i386-redhat-linux' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--with-mime-magic=/etc/httpd/conf/magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--without-odbc' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter'

    Notice the –without-mysql


    This is a bog-standard Fedora Core 5 installation. Does this mean I have to compile PHP from source?

    Please tell me that this is not the problem. Please tell me there’s another way.

    Help! Please….


Viewing 10 replies - 1 through 10 (of 10 total)
  • whooami



    just go grab apache toolbox (google it) and let it do the work for you. Just check off the boxes to make sure apache is compiled with php and mysql support — its not too hard, will take you 15 mins or so with AT.

    Thanks Whooami

    I’ve looked into Apache Toolbox and I might have a go in a minute – but before I do…

    Is my problem really with Apache or is it with PHP?

    I thought the test I was doing with the <?php phpinfo(); ?> was to test my PHP installation. Is that where my problem lies?

    Thanks again





    thats your PHP.

    below that, middle ways down, is your Apache setup.

    Ummm – The way I read it those are the configuration options that RedHat used to build the PHP installation on my system. I think Apache is running OK.

    Would rebuilding Apache solve my problem?

    Thanks again





    You sounded like you didnt want to go to the trouble of having to do a manual recompile of php in your first post.

    Apache toolbox will do e v e r y t h i n g, after you check off the right boxes. You tell it you want php/mysql support, it goes out, downloads the tars, checks them, and does the work while you wait.

    You could always just do a manual recompile of PHP though, its entirely up to you.

    Apache Toolbox has it’s advantages though as the author is VERY good about keeping up with security updates, so youre assured of always getting the latest release of whatever youre installing.




    doublepost — got some wierd timeout thing, sorry.

    OK – Sounds good. Before I go ahead and do it though – can you just confirm that it is the cause of my problem.

    Am I the only Fedora Core 5 user who has tried to install WordPress?

    Surely a standard install of FC5 with Apache, PHP, MySql etc would have them all talking to one another?

    There is nothing wrong with my php.ini or wp-config.php settings?

    Thanks again





    if php is NOT talking to MySQL, then your blog wont work — it’s as simple as that.

    Its called: LAMP


    you need all 4 of em working together.

    Based on your paste, you do NOT have MySQL support compiled into php (that is a standard install btw, Mandrake does the same thing, leaving off MySQL)

    OK Thanks for that.
    I’ve been looking at Apache Toolbox but it seems to want to remove my 5.1 versions of PHP to be replaced by 5.0.2 (I have run –update)

    Testing for PHP RPM… found! Please remove the rpm. EG: rpm -e php-5.1.4-1
    Testing for PHP IMAP RPM… not found.
    Testing for PHP LDAP RPM… found! Please remove the rpm. EG: rpm -e php-ldap-5.1.4-1
    Testing for PHP PGSQL RPM… not found.
    Testing for Apache RPM… not found.
    Testing for Apache Devel RPM… not found.
    Testing for Mod_Perl RPM… found! Please remove the rpm. EG: rpm -e mod_perl-2.0.2-5.1
    Testing for Mod_Perl Devel RPM… not found.
    [+] ** If your going to use an RPM package (like openssl) you better have the DEVEL rpm installed as well! **
    RPMs that will probably cause problems where found!
    Do you wish to continue anyway? (be careful) [y/n] n
    [root@ArthurDent Apachetoolbox-1.5.72]#

    Is this wise?

    Thanks again.



    In actual fact all I had to do was to use the FC5 package manager (yum or yumex) to install php-mysql (and its dependencies), restart Apache and I’m up and running! Yay!

    Thanks to all especially whooami

    Now on to step 6 of the 5 minute install…. ahem…

    Thanks again


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘missing the MySQL….’ is closed to new replies.