Support » Plugin: Gutenberg » Missing tags and categories

  • Resolved 123blogger

    (@123blogger)


    What the title says. I’m sure I looked everywhere on the sidebar and all, but there seems to be no way to edit categories and tags on my blog posts with the new editor… am I missing something? Why? How to fix?
    My sidebar, if that’s of any help: https://imgur.com/a/AbFCVRv

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Marius L. J.

    (@clorith)

    Hi,

    You should be able to edit them as normal in the sidebar area you are looking at, for reference, here’s mine:

    Sidebar document settings

    Is this a regular post (where you go to Posts in the admin menu) or a custom made post type?

    If it is a regular post, there may be a plugin or theme conflict causing this (I do see in your screenshot that something else exists there), testing for conflicts is fairly simple, you just disable your plugins and use a default theme (such as Twenty Seventeen). We understand that’s not always ideal so there is a helper plugin, Health Check, which will let you do this for your users only when using its Troubleshooting Mode.

    Well, I guess a plugin might be interfering as it is a normal post. But I think I’ve found a way around that. I first open the post in normal editor and set category/tags, and only then do I switch to gutenberg, as it is a good editor. But if there’s a way to fix it, please try 😕 thanks

    Moderator Marius L. J.

    (@clorith)

    Would you be able to share which plugins you have installed so we can try to replicate it, as we want to try to prevent this from happening, or if you have a chance to use the other plugin I mentioned to identify it for us that would also be awesome but I understand that it may not be the most exciting thing to be doing so don’t worry about that bit too much.

    The plugin is too confusing, heh. I quit Gutenberg, it’s problematic (at least for me) but if this is fixable I might return to using it… If it’s the plugins fault, they’re as following (or were at the time I used Gutenberg):
    Akismet Anti-Spam
    Contact Form 7
    Favicon by RealFaviconGenerator
    FooGallery + FooBox Image Lightbox
    iThemes Security
    Jetpack by WordPress.com
    Page Builder by SiteOrigin + SiteOrigin Widgets Bundle
    Spacious Footer Editor (I only got that yesterday off the internet, it wasn’t causing the problem so don’t worry about it)
    UpdraftPlus – Backup/Restore (was deactivated until yesterday, so probably didn’t cause the problem)
    Yoast SEO
    Deactivated plugins: Google XML Sitemaps, Gutenberg

    Thanks.

    iThemes Security is the conflict.

    The option that controls this functionality is located under WordPress Tweaks > REST API in the iThemes Security settings.

    Changing the setting to Default Access will display Categories and Tags in the Gutenberg editor.

    https://ithemes.com/security/wordpress-rest-api-restrict-access/

    Alternatively, you can keep the iThemes setting intact to Restricted Access, then check off categories and add tags on Posts page > Quick Edit.

    Wow, that actually worked! Thank you Gingalley!

    Yep, wow! Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Missing tags and categories’ is closed to new replies.