Support » Plugin: Leaky Paywall for WordPress » Missing Subscribe Button

  • Hi,

    I have set up the plugin however when I came to test it there is not button to press on the subscription card. Hoping you can help.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Jeremy Green

    (@endocreative)

    Hello. What payment gateway do you have selected in the Leaky Paywall settings, and have you entered the appropriate API keys (Stripe or Paypal)?

    I’ve selected the Stripe checkout popup and Ive got both the live keys and the test keys for stripe filled out under stripe settings.

    Plugin Contributor Jeremy Green

    (@endocreative)

    Looks like you have a plugin called Direct Stripe that may be interfering with it. Can you disable that plugin and see if button display correctly afterwards?

    Thats worked, many thanks. I am now running into the issue that subscribers cannot see whats behind the paywall and asks them to subscribe although they are already subscribed and logged in. I have the post setting set to leaky paywall defaults. The default being that their level of membership should be able to see said posts.

    They are reporting that their accounts ‘Deactivated’, I’ve checked and it says they are in fact active.

    Plugin Contributor Jeremy Green

    (@endocreative)

    If you install the User Switching plugin, you can use its “Switch To” functionality and test out the site as them to try and troubleshoot the problem.

    https://wordpress.org/plugins/user-switching/

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.