WordPress.org

Support

Support » How-To and Troubleshooting » Missing Stylesheet

Missing Stylesheet

  • I’m using the latest build of WordPress. The default stylesheet looks OK in Internet Explorer and Konqueror, but the style is totally missing on Firefox and Mozilla, so the layout is UGLY. Any ideas about where to start looking for a problem?
    PEB

Viewing 13 replies - 1 through 13 (of 13 total)
  • Mark (podz)
    Support Maven

    @podz

    Keep refreshing .. I saw this behaviour in a friends WP install last night. All of a sudden it just got better… odd.
    A moz quirk maybe ?

    Laughinglizard
    Member

    @laughinglizard

    Could you give us an URI to look at?

    The URI is http://skytoucher.com/wp/
    I tried the reload trick with Mozilla. Nothing happened.
    Another puzzling thing is that Mozilla uses the stylesheet correctly when running a local copy of WordPress that I use for testing. The problem I have is with the remote copy.
    The local version (on linux) is: WordPress 1.0.1
    The skytoucher.com version is: WordPress 1.2-alpha
    I made sure the stylesheets were identical for the two locations.
    Maybe this is a timeout problem of some sort.
    PEB

    Mark (podz)
    Support Maven

    @podz

    Odd. Using Firefox, I see no styling. I then right click to use the inline CSS editing extension, and the page switches to the correct view.
    Could it be related to the @import ?

    NuclearMoose
    Member

    @nuclearmoose

    peb and podz,
    I just checked the site w/Firefox as well. It looks like a NN4 site, until I try to use the EditCSS extension the same as podz did, and then the site works. I checked the @import, and it is identical to mine, save the obvious URI differences.
    What if you tried to install 1.02 instead of 1.2 Alpha? Maybe there is something in 1.2 Alpha that is mucking this up. Very strange.
    Craig.

    Ok, per Criag’s suggestion, I installed version 1.02 — same result, i.e,. stylesheet doesn’t show.
    Really puzzling.
    PEB

    NuclearMoose
    Member

    @nuclearmoose

    peb,
    I’ve posted a question at the Community MX forums, hoping that one of their gurus might be able to spot a problem.
    Very strange. Perhaps this is a bug in the newest builds of Moz/Firefox.
    Craig.

    Everyone – Thanks for the help. I’ve contacted the server to see if they can correct the problem. I hope so. I don’t want change servers right now. The server problem would explain why these pages are served correctly from my local server and not the skytoucher.com location.
    PEB

    There’s a little more about it here: http://www.xml.com/pub/a/2003/03/19/dive-into-xml.html
    I think I recall from some HTML newsgroups (i.e. comp.infosystems.www.authoring.html) that a person might be able to do something with mod_rewrite (or was it .htaccess?) if you’re enabled for those and can’t get relief from your host admin. The concensus also seemed to be that most sites should just be written for html 4.01 doctype (partly to avoid this very problem), unless xml is actually needed for functionality objectives, which it probably is for certain blogging features. I’ve also run across some discussions that this issue can result in the site getting overlooked by google, but I wouldn’t go so far as to vouch for that myself. Until now, I’ve been writing most everything in html 4.01 strict w/ css2.0.
    Good luck with your host admin. Some are admirably responsive, others are…. well, don’t get me started.

    Any update on if this can be changed in .htaccess or in a similar fashion?

    The problem appears to be resolved. The server added a mime type so that a text/css header is now returned for .css files. The pages now appear to render correctly – even in Firefox. I woudn’t have thought to look for a header problem. Thanks for the troubleshooting help.
    PEB

    I have exactly this problem (missing stylesheet), but it’s caused by something different. When I check the CSS file on http://www.rexswain.com/cgi-bin/httpview.cgi, it returns “Content-Type:·text/css”. Just like it’s supposed to, right? Also, other pages on my website display fine in Mozilla and Opera – CSS intact – so I’m guessing it’s not my server. It’s just WordPress. I’m using Style-Switcher, and everything looks fine in IE. The other pages don’t use @import. Is that important?
    My site (still testing, not much content).
    My CSS file (messy, I know – I’m experimenting!)
    I don’t know anything about anything. Please help me!
    Oh – using 1.2-Mingus.
    Cheers,
    Anthony

    As I understand your problem your url to the css seems to be wrong. The url you posted here is pointing to the company . I am assuming it is a joke. However in the meantime a quick glance at your site it its unstyled form is very useful for other purposes.As you are set out at the moment you have your links before the content. This is going to give you a whole host of problems, is damaging your accessibility, and will screw your search engine ranking. Other than that it is fine.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Missing Stylesheet’ is closed to new replies.