• Resolved LinkAssist

    (@linkassist)


    Greetings –
    I’m using WordPress 4.9.4 with a free theme (Divogue 1.4.4). The theme’s documentation says it will display sidebars if it’s used with the Custom Sidebars plugin.
    I’m trying to get a sidebar on the right side of all my pages, but initially I just tried getting it to appear on the front page. I enabled the Primary Sidebar to be replaced, and created a new sidebar under “Custom Sidebars”. I named and described the new sidebar, and added a menu widget in the sidebar.
    For sidebar location I clicked on “For Archives”, “Archive Types”, then “As Primary Sidebar for selected Archive Types”. Finally, I selected “Front Page” from the Archive field dropdown. I purged all the caches in W3 Total Cache and took a look at the front page, but there was no sidebar on the page.
    What have I missed?
    Thanks – Dennis

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello there @linkassist,

    hope you’re doing good today and thanks for reaching us! 🙂

    I’ve just tried to replicate this and seems to work well.

    Sidebar/Widget settings:

    Before:

    After:

    Which widget were you using during this? I mean in the Custom Sidebar?
    Maybe the widget you select, doesn’t have any content to display at all?
    Or are you trying to replace another sidebar location?
    Please advise!

    Warm regards,
    Dimitris

    Thread Starter LinkAssist

    (@linkassist)

    Hi @dimitris! Thanks for the quick response- and with some excellent screen captures 🙂

    I retraced your steps and had no problem – the search widget showed up at the top of the page, just as it did for you.

    I removed that custom sidebar and went through the same steps to put the search widget in the primary sidebar (on the right side of the front page), but nothing appeared.

    Any clues? Thanks again – Dennis

    • This reply was modified 6 years, 3 months ago by LinkAssist.
    • This reply was modified 6 years, 3 months ago by LinkAssist.
    Thread Starter LinkAssist

    (@linkassist)

    I’ve made progress sorting out the problem. The theme author sent an email saying the front page never shows the primary sidebar – that it’s always shown as full page.

    So I took a look at an interior site page, and sure enough the sidebar appears. I’m still sorting out how to use the Sidebar Location option box for Custom Sidebars though. I had to turn on every option in that box initially to finally make the search widget appear – but I did finally get it to show up. Now I just need to play with it to understand how Custom Sidebars works. That part of the plugin hasn’t been too user friendly for me.

    Thanks for your help!

    Dennis

    • This reply was modified 6 years, 3 months ago by LinkAssist.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Missing sidebar after activation & set up’ is closed to new replies.