Support » Plugin: Language Switcher for Elementor » Missing settings in the Style tab of the widget

  • Resolved caum

    (@caum)


    Hi,
    Thanks for this plugin so useful to make WPML a bit more friendly user.

    I noticed few things missing compared to the screenshots on the plugin page and I don’t think it’s normal.
    – Screenshot Backend 2: I only have 2 settings in the Style tab of the widget (Main menu and Language code) although I can see Country Flag, Native Name, Translated Name on the Screenshot 2.
    – Demos 1 to 4 Screenshots: you always display a vertical separator between each language name. I don’t have this and I don’t how to make it.

    Thanks for your help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Solitweb

    (@solitweb)

    Hi,

    To see all the style options you have to enable them first under the content tab. So if you want country flags, you have to enable Show Country Flag under the content tab.

    If you want the vertical separator you have to set the Border Type to Solid and set all the widths to 0 except for Right. And choose a color. If you don’t want the last child to have a right border you can add this custom css under the Advanced tab:

    
    selector .lsfe-menu > li:last-child {
        border: 0 !important;
    }
    

    I hope this info helps you to build a great project!

    Thread Starter caum

    (@caum)

    Hi,

    All this is very logic and simple. I though you handle the vertical separator as a border with css but I was not sure.
    A suggestion: it could be a great development if you can add a setup for graphic separator (vertical line, bullet, icons…).
    And it would great to have your plugin for Polylang.
    Anyway, thanks again!

    Hi,

    I have installed the plugin and actived it. I also inserted it into my header template i made in Elementor Pro.

    Now i want to configure it, but i cant. The first screenshot you show in the “Details” tab of this plugin page is missing, where you can adjust the layout and alignment. I can only check the boxes what i want to see (display language names, flags, etc.). Also, the style tab is missing where padding can be adjusted…

    What am i doing wrong?

    Thank you,
    Anthony

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Missing settings in the Style tab of the widget’ is closed to new replies.