Support » Plugin: Grids: Layout builder for WordPress » Missing Settings

  • Resolved NicheLabs

    (@allennichelabs)


    The documentation and screenshots both show a couple of tabs at the top of the Grids block but when I add a new grid it only shows a multicolored grid tab and a 3 dotted tab for more options.

    The name of the block is labeled Section and not Grids so maybe I’m doing something wrong. I’m trying to get to the point where I can select a background and set it to “stretch” but that option doesn’t appear.

    According to the screenshotI have to select “Wide Width” from the tab at the top of the block, but I don’t have that tab. What am I missing???

Viewing 5 replies - 1 through 5 (of 5 total)
  • NicheLabs

    (@allennichelabs)

    Ok it appears to be an issue with my custom theme. I disabled all the plugins and I still had the problem. I switched to twentynineteen and not I see the other tabs and can set it to “wide” and see the “Extend to viewport sides”.

    So now I have to determine what it is about my theme.

    NicheLabs

    (@allennichelabs)

    Well it’s not my theme, I just activated Twenty8teen and it does the same thing as my theme. Is this dependent on something that TwentyNineteen uses?

    Joy

    (@joyously)

    The block editor added some new add_theme_support possibilities. Some themes support them, and some do not. Twenty Nineteen supports wide-blocks. Twenty8teen does not. (I am author of Twenty8teen.)

    Plugin Contributor Andrea Gandino

    (@andg)

    Hi @allennichelabs, first of all thank you for trying out Grids! 🙂

    Secondly, as @joyously said, not all themes support the wide alignment for blocks within the Block Editor, that’s why on some of them certain Grids settings are not shown (this goes for other first-level blocks too).

    NicheLabs

    (@allennichelabs)

    Ok thanks. By adding add_theme_support( ‘align-wide’ ); to my functions.php file I am now able to get the settings I’m looking for.

    It might be helpful to mention that somewhere in the documentation.

    Again, thank you for your help.

    Allen

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.