WordPress.org

Support

Support » Multisite » Missing roles, invisible users on subsites

Missing roles, invisible users on subsites

  • I’ve noticed that some of the subsites on the multisite install have empty dropdowns on the user roles screen and also some of the sites have additional admins, but dont show them.

    Is there an easy way to fix/reset user roles?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Same problem! No user roles for subsites (normal for main site) of networks. If one does add a user without a role, this user doesn’t even show up in the all users list on the subsite dashboard, so one still cannot change the user’s role. The total number of users does count the non-visible user though. The only place one still has access to this new user is in the network or main site user panel.

    Seems to be an underlying problem as after installing the Multisite User Management plugin, I get the same problem: dropdown to select default role of new users for main site works just fine, no roles for subsite dropdown.

    Frustrating!

    Found a solution: http://wordpress.stackexchange.com/questions/11725/help-why-my-roles-are-not-showing-multi-site-network

    Problem for me: I had installed the Better WordPress Security plugin and changed my database prefix via this plugin. As a consequence the entry wp_[blog ID]_user_roles should really be named [prefix]_[blog ID]_user_roles. BWPS does this for the main blog but fails to do this for sub-sites at the moment. So went into phpMyAdmin and fixed it. Works a charm.

    Hope this helps.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Missing roles, invisible users on subsites’ is closed to new replies.